This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Extensions » eZ Flow » eZFlowOperations and ini-instance of...
expandshrink

eZFlowOperations and ini-instance of 'block.ini'

eZFlowOperations and ini-instance of 'block.ini'

Friday 13 March 2009 11:22:16 am - 4 replies

(I first put this under developer forum but I guess this is the proper place for my topic...)

Hi!
I have just recently started to laborate with eZ Flow and it seems like a great extension to me so far. I have now a question regarding dynamic blocks.

I have created my own dynamic block and I have specified the details in block.ini.append.php in ez403/settings/siteaccess/my_site/ and ez403/settings/siteaccess/my_site_admin/ It shows up in the admininterface and collects the items like it should. But the automatic is not working at all. I have used FetchClass=eZFlowLatestObjects. I publish a new article to the source but nothing happens when I run the cronjob.

I did a print_r of the variable blockINI in eZFlowOperations class. My new block is not available there. It looks like it is only the configurations in block.ini in extension/ezflow/settings/. Is it not possible to make an override of the block.ini and put it in my siteaccesses? Can I only put this configuration in the extension? All manual blocks in my configuration in ez403/settings/siteaccess/my_site/block.ini.append.php works fine. It is only when it comes to running the cronjob it fails.

Thanks in advance!

Anja Lundin, Novitell AB, Sweden

Friday 13 March 2009 11:52:28 am

Hi,

try to put your block.ini in ez403/settings instead of ez403/settings/siteaccess/my_site_admin/.

If it's not working, try to specify the siteaccess when running the cronjob :

php runcronjobs.php -smy_site_admin ezflow

Ly

Friday 13 March 2009 12:33:48 pm

I have now put the blocks in block.ini.append.php in extension/ezflow/settings/siteaccess/my_site and /my_site_admin

When I run cronjobs I always use " -s my_site "... happy.gif Emoticon

Still no change.

Do I really have to put the new blows directly in block.ini under ezflow/settings? I need to have different blocks for different siteaccesses....

Thursday 14 May 2009 10:01:04 am

Hi, Anja,

I had the same problem as yours - I needed different blocks for the different siteaccesses in my project. The first thing that I did was to put my custom block.ini files in each of the siteaccesses. I think in your case you already did that as you put them respectively in ez403/settings/siteaccess/my_site/ and ez403/settings/siteaccess/my_site_admin/. Now, try to comment the defined blocks in the block.ini file of the ezflow extension. This way that file won't override your custom block.ini files as the system will take only your blocks definitions, but not those in the extension. That helped in my case.

I hope my post could be useful, but in case you already found another more efficient solution, I'll appreciate if you share it in the forum!

Good luck!

Modified on Thursday 14 May 2009 10:06:08 am by Elena Stoycheva

Friday 15 May 2009 8:11:08 am

Hi Elena!
It seems to work (so far). Thank you very much!

Best regards

Anja Lundin, Novitell AB, Sweden

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from