This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Extensions » ez multiupload not work properly
expandshrink

ez multiupload not work properly

ez multiupload not work properly

Sunday 02 October 2011 10:00:00 am - 12 replies

Hallo!
Installed a new version of the Community Project 2011.9
Started testing. Extension ez multiupload does not work .
In the toolbar click the multiupload-icon being in the node - gallery
page is loaded: Multiupload
The files are uploaded to My gallery
all as it should - button Select Files, push
choose to test only one file, there is a progress bar, bar is filled to 100% and hangs, nothing happens, the file did not get to the gallery. In the admin area expansion does not work either.
It is suspected that the problem in the settings of the hosting of directives.

Sunday 02 October 2011 2:21:23 pm

I've tested with ezwebin and it's working fine here, with one or multiple files.

Sunday 02 October 2011 4:24:28 pm

Hello Maxim,

I'm sorry your having trouble. I've been in the same position as you before (many years ago when this extension was first released), it just didn't work (but then again the installation problems were all my own ignorance). I've only ever seen the problems you describe when it was not installed correctly or if the hosting requirements where not being met...

Once I overcome those problems it has been clear sailing.

Have you read this pdf on requirements and installation of the extension? It's not been updated in a while but I still think it's a valuable resource, https://github.com/ezsystems/ezmultiupload/blob/master/doc/doc_eng.pdf

alternatively there is also the online docs, http://doc.ez.no/Extensions/eZ-Publish-extensions/eZ-Multiupload

http://doc.ez.no/Extensions/eZ-Publish-extensions/eZ-Multiupload/eZ-Multiupload-1.1.0-user-manual

I hope this helps ...

Cheers,

Heath

Monday 03 October 2011 8:59:28 am

Hallo Heath,
 Thank you for your reply!
 I downloaded the latest version from github and fixed, but does not work either.
 Yes, I think the problem on the side of the host. What should I configure the hosting-server multiupload extention to work?

PHP Core

Directive

Local Value

Master Value

allow_call_time_pass_reference On On
allow_url_fopen On On
allow_url_include On On
always_populate_raw_post_data Off Off
arg_separator.input & &
arg_separator.output & &
asp_tags Off Off
auto_append_file no value no value
auto_globals_jit On On
auto_prepend_file no value no value
browscap no value no value
default_charset utf8 no value
default_mimetype text/html text/html
define_syslog_variables Off Off
disable_classes no value no value
disable_functions no value no value
display_errors Off Off
display_startup_errors Off Off
doc_root no value no value
docref_ext no value no value
docref_root no value no value
enable_dl On On
error_append_string no value no value
error_log no value no value
error_prepend_string no value no value
error_reporting 8191 6135
expose_php Off Off
extension_dir /opt/php5/lib/
php/exts/
/opt/php5/lib/
php/exts/
file_uploads On On
html_errors On On
ignore_repeated_errors Off Off
ignore_repeated_source Off Off
ignore_user_abort On Off
implicit_flush Off Off
include_path .:./lib/ezc:.:
/opt/php5/lib/php:/opt/php5/lib/ZendFramework/
library
.:/opt/php5/lib/php:
/opt/php5/lib/ZendFramework/
library
log_errors On On
log_errors_max_len 1024 1024
magic_quotes_gpc Off Off
magic_quotes_runtime Off Off
magic_quotes_sybase Off Off
mail.force_extra_parameters no value no value
max_execution_time 150 50
max_file_uploads 20 20
max_input_nesting_level 64 64
max_input_time 180 60
memory_limit 128M 64M
open_basedir no value no value
output_buffering 4096 4096
output_handler no value no value
post_max_size 64M 20M
precision 14 14
realpath_cache_size 16K 16K
realpath_cache_ttl 120 120
register_argc_argv On On
register_globals On On
register_long_arrays On On
report_memleaks On On
report_zend_debug On On
safe_mode Off Off
safe_mode_exec_dir no value no value
safe_mode_gid Off Off
safe_mode_include_dir no value no value
sendmail_from no value no value
sendmail_path /usr/sbin/
sendmail -t -i 
/usr/sbin/
sendmail -t -i 
serialize_precision 100 100
short_open_tag On On
SMTP localhost localhost
smtp_port 25 25
sql.safe_mode Off Off
track_errors Off Off
unserialize_callback_func no value no value
upload_max_filesize 50M 50M
upload_tmp_dir no value no value
user_dir no value no value
variables_order GPCS GPCS
xmlrpc_error_number 0 0
xmlrpc_errors Off Off
y2k_compliance On On
zend.ze1_compatibility_mode Off Off

Does anyone have any ideas?

If the problem is hosting, where?

Modified on Monday 03 October 2011 9:05:11 pm by Maxim Kopytov

Tuesday 04 October 2011 12:25:25 am

Have you checked the ez publish's log files?

Have you configured image.ini to use GD or ImageMagick, is GD or ImageMagick installed on your hosting?

Have you tried to upload an image that is coming from the internet? Try downloading the logo of eZ on this page and upload it. Some JPEG have broken EXIF and might fail the upload.

Tuesday 04 October 2011 3:19:33 am

Hello Maxim,

I would use the Firefox or Chrome Browser and repeat your test upload process paying special attention to any javascript error console errors which may be occurring as well. It sounds like the file is not being uploaded at all (based on your first message). Also please be more verbose about what errors your experiencing as details here are key.

I don't see anything specifically wrong with the php configuration you've shared. Though I might turn on the display_errors = On for testing purposes ...

Also, I would listen to Quoc Huy Nguyen Dinh suggestion to review the latest entry to the eZ Publish log files (see ezpublishdir/var/logs/*.log files) as they very well could contain additional details which might help troubleshoot this problem.

I hope this helps...

Cheers,

Heath

Tuesday 04 October 2011 5:20:28 am

Have you checked the ez publish's log files?

Have you configured image.ini to use GD or ImageMagick, is GD or ImageMagick installed on your hosting?

Have you tried to upload an image that is coming from the internet? Try downloading the logo of eZ on this page and upload it. Some JPEG have broken EXIF and might fail the upload.

Hi!

There are no problems when I add a file without using the ezmultiupload
Images are scaled, are aliases, then Image Magick works

There are no errors in var/log/error.log file.

I tried to upload different pictures in different formats.
 On the other hosting the module works!

 
 I just want to understand why it does not work here!
 I would like to solve this problem once and for all.

Here information about my hosting extentions:

date, libxml, openssl, pcre, zlib, bcmath, bz2, calendar, ctype, curl, dba, dom, hash, filter, ftp, gd, gettext, gmp, session, iconv, standard, interbase, json, mbstring, mcrypt, mhash, mssql, mysql, SimpleXML, SPL, PDO, pdo_mysql, pdo_sqlite, posix, pspell, Reflection, imap, shmop, mysqli, soap, sockets, SQLite, exif, sysvsem, sysvshm, tokenizer, wddx, xml, xmlreader, xmlrpc, xmlwriter, xsl, zip, apache2handler, ffmpeg, pdf, imagick, dbase, tidy, geoip, pgsql, pdo_pgsql, ionCube Loader, Zend Optimizer

Apache mods:

core, mod_charset_lite, mod_cache, mod_disk_cache, mod_mem_cache, mod_proxy, proxy_connect, proxy_ftp, proxy_http, prefork, http_core, mod_status, mod_asis, mod_imap, mod_userdir, mod_so, mod_access, mod_auth, mod_auth_dbm, mod_include, mod_log_config, mod_env, mod_expires, mod_headers, mod_setenvif, mod_mime, mod_autoindex, mod_cgi, mod_negotiation, mod_dir, mod_actions, mod_alias, mod_rewrite, mod_ssl, mod_security, mod_dp20, mod_php5, mod_python, mod_ruby, mod_wsgi

GD

GD Support enabled
GD Version bundled (2.0.34 compatible)
FreeType Support enabled
FreeType Linkage with freetype
FreeType Version 2.3.4
GIF Read Support enabled
GIF Create Support enabled
JPG Support enabled
PNG Support enabled
WBMP Support enabled
XBM Support enabled

Imagic

imagick module

enabled

imagick module version 3.0.0
imagick classes Imagick, ImagickDraw, ImagickPixel, ImagickPixelIterator
ImageMagick version ImageMagick 6.6.2-5 2010-09-14 Q16 http://www.imagemagick.org
ImageMagick copyright Copyright (C) 1999-2010 ImageMagick Studio LLC
ImageMagick release date 2010-09-14
ImageMagick number of supported formats: 193
ImageMagick supported formats 3FR, A, AI, ART, ARW, AVI, AVS, B, BGR, BGRA, BMP, BMP2, BMP3, BRF, BRG, C, CAL, CALS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CRW, CUR, CUT, DCM, DCR, DCX, DDS, DFONT, DNG, DOT, DPX, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, ERF, FAX, FITS, FRACTAL, FTS, G, G3, GBR, GIF, GIF87, GRADIENT, GRAY, GRB, HALD, HISTOGRAM, HRZ, HTM, HTML, ICB, ICO, ICON, INFO, INLINE, IPL, ISOBRL, J2C, JNG, JP2, JPC, JPEG, JPG, JPX, K, K25, KDC, LABEL, M, M2V, M4V, MAP, MAT, MATTE, MIFF, MNG, MONO, MOV, MP4, MPC, MPEG, MPG, MRW, MSL, MSVG, MTV, MVG, NEF, NULL, O, ORF, OTB, OTF, PAL, PALM, PAM, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PGX, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG24, PNG32, PNG8, PNM, PPM, PREVIEW, PS, PS2, PS3, PSB, PSD, PWP, R, RADIAL-GRADIENT, RAF, RAS, RBG, RGB, RGBA, RGBO, RLA, RLE, SCR, SCT, SFW, SGI, SHTML, SR2, SRF, STEGANO, SUN, SVG, SVGZ, TEXT, TGA, THUMBNAIL, TILE, TIM, TTC, TTF, TXT, UBRL, UIL, UYVY, VDA, VICAR, VID, VIFF, VST, WBMP, WMV, WPG, X3F, XBM, XC, XCF, XPM, XPS, XV, Y, YCbCr, YCbCrA, YUV

Directive

Local Value

Master Value

imagick.locale_fix 0 0
imagick.progress_monitor 0 0

My image.ini.append settings:

 <?php /* #?ini charset="utf-8"?
 
[ImageMagick]
IsEnabled=true
ExecutablePath=/usr/bin
Executable=convert
*/ ?>

Modified on Wednesday 05 October 2011 10:57:04 am by Maxim Kopytov

Tuesday 04 October 2011 10:39:35 am

Some hosts might have installed convert in another path, such as /usr/local/bin, you might want to try that or use http://www.rubblewebs.co.uk/imagemagick/server/command.php to locate the path.

Also don't forget to test javascript as mentioned by Heath

Modified on Tuesday 04 October 2011 10:40:26 am by Quoc-Huy NGUYEN DINH

Tuesday 04 October 2011 1:34:46 pm

Some hosts might have installed convert in another path, such as /usr/local/bin, you might want to try that or use http://www.rubblewebs.co.uk/imagemagick/server/command.php to locate the path.

Also don't forget to test javascript as mentioned by Heath

Thank You for Your answer, but have you read my previous post?
 I wrote:

There are no problems when I add a file without using the ezmultiupload
Images are scaled, are aliases, then Image Magick works

For code:

 <?php
echo "<pre>";
system("type convert"); 
echo "</pre>";
?>

server answer me:

 convert is /usr/bin/convert

Where ezmultiupload stores the temporary files?
May be a problem in the directive open_basedir or upload_tmp_dir?

On the other hosting the extension ezmultiupload works!
I want to find out for yourself and for the community, which features host does not allow the ezmultiupload to work correctly.

Modified on Wednesday 05 October 2011 6:18:44 am by Maxim Kopytov

Wednesday 05 October 2011 7:04:25 am

Hello Maxim,

Yes, we are all well aware of what you wrote.

Also open_basedir + eZ Publish is not supported (to my memory)

The default temp dir is /tmp I believe but this does not need to be set (but you could try)

The thing is, not all features of eZ Publish, works on all types of hosting. This varies greatly from each hosting provider uniquely and can be extension specific.

You your self uniquely hold the ability to compare the two different types of hosting better than any of us ever can through a forum. You should compare the two and report back here with any relevant differences (that you can discover).

 

Best wishes

Cheers,

Heath

Wednesday 05 October 2011 10:30:54 am

Heath, I contacted the hosting company.
Technical support has found a solution.
They disabled the security module mod_security in the .htaccess file 

SecFilterEngine Off

In connection with disabling security module are advised to consult with the developers of eZ Publish CMS
Would not disabling mod_security module to cause problems?

If the work site scripts are used the vulnerabilities that are now suppressed by the use of the module
security, after disabling the sec. module, these vulnerabilities are available,
so attackers can hack the site.

What about it will tell the developers?

Modified on Wednesday 05 October 2011 10:36:39 am by Maxim Kopytov

Wednesday 05 October 2011 2:58:09 pm

Hello Maxim,

It comes as no surprise that eZ Publish ezmultiupload extension is not compatible (out of the box in your hosting env) with extra mod_security module. And no I do not think you are not more vulnerable by disabling the -not needed- mod_security module to to use the eZ Publish ezmultiupload extension or eZ Publish in general. eZ Publish built in security is very good.

Tell the developers the site is online end ready to use. Enjoy!

Cheers,

Heath

Wednesday 05 October 2011 5:13:04 pm

As Heath said, eZP security track record is quite good.

Most of the users of the CMS afaik just expose it to the internet (behind an ip-layer-firewall) without adding an extra application-level-firewall such as mod_security, and so far no one has sued us for their site having been hacked happy.gif Emoticon

If the site was working with mod_security on, it should not break (in functionality) with mod_security off, as mod_security is meant to be transparent, not to do any modifications on incoming requests.

It would be nice to know which one of the mod_security rules was getting triggered from ezmultiupload (and the version of mod_security in use), so that we can maybe replicate the error and fix it in the future.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from