eZ Community » Forums » Extensions » eZ Newsletter » Installation problems
expandshrink

Installation problems

Installation problems

Tuesday 15 December 2009 2:49:05 pm - 3 replies

I've got a problem with my 'Newsletter' and 'Newsletter Setup' tab links.

I took a clean install of ez4.0 and added the ez1.6 beta newsletter during the setup wizard. Everything seemed to work perfectly but upon logging into the [my_site]/newsletter_editor/ my 'Newsletter' and 'Newsletter Setup' tab links don't work. For example when I try Newsletter Setup I'm met with:

"Fatal error: Class 'eZNewsletterTemplateWrapper' not found in /home/my_site/public_html/ezfourzero/extension/eznewsletter_builder/modules/newsletter_setup/general.php on line 77
Fatal error: eZ Publish did not finish its request

The execution of eZ Publish was abruptly ended, the debug output is present below."

What am I doing wrong?

Monday 21 December 2009 11:30:52 am

You try to regenerate autoloads?

Monday 21 December 2009 4:44:15 pm

Under the extensions link in the admin side I tried the "Regenerate autoload arrays for extentions" but was greeted with:

Fatal error: Class 'ezcFile' not found in /home/peoples/public_html/ezfourzero/lib/ezutils/classes/ezautoloadgenerator.php on line 283
Fatal error: eZ Publish did not finish its request

The execution of eZ Publish was abruptly ended, the debug output is present below.

Is there another way to regenerate autoloads?

Monday 21 December 2009 10:43:33 pm

You can do that via the command line script, but you would get the same error - you need to have the eZ Components installed and available for include in your php's include_path...

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from