eZ Community » Forums » Extensions » ezfind STOP words causing problems
expandshrink

ezfind STOP words causing problems

ezfind STOP words causing problems

Friday 04 May 2012 3:46:30 pm - 5 replies

Tested on ezfind 2.5 on ez 4.5 Enterprise

Before I put in a support ticket.. Simple scenario.

search for 'Happiness on the earth' using content/search = No results

search for 'Happiness the earth' = lots of results

search for 'Happiness earth' = lots of results

clearly the 'on' is breaking the search. Some research into this shows that 'on' and other terms are 'STOP WORDS' .. So this is a problem.

The string cannot be quoted becuase then legitamite quoted searches would not work (be to narrow).

I'm tempted to find a list of stop words and simply strip them from the search string just before the fetch.

This looks to be a gross oversight on ezfind functionality.

Please provide a recommendation to solve this.

Friday 04 May 2012 7:25:38 pm

1. what about removing "on" from the stopwords list?

2. not sure what you mean by "The string cannot be quoted because then legitimate quoted searches would not work (be to narrow).": can't you analyze the string, looking for stopwords, and if any are found quote it (unless it is already quoted)?

Thursday 03 October 2013 11:38:46 am

Hi, I have the same issue here, when i'm searching for a string like "image of the month" it does not return anything but if i search for "image of month" or "image the month" it returns results.

I already tried to remove the stopwords "of" and "the" from the stopwords.txt but it does not change anything. I also applied this patch but didn't work : https://jira.ez.no/browse/EZP-19445

Friday 04 October 2013 3:46:00 am

Note that the default config of eZFind has a rule set telling solr how many words have to be matched out of the total.

This leads to surprising results, as sometimes adding more words results in less matches (eg. if 2 out of 3 are needed and 3 out of 4 as well, then adding a stopword will decrease result set).

I think removing stopwords from the list should fix your symptoms. Did you reindex the whole content after changing the list?

Tuesday 08 October 2013 12:35:48 pm

Quote from Gaetano Giunta :

Note that the default config of eZFind has a rule set telling solr how many words have to be matched out of the total.

This leads to surprising results, as sometimes adding more words results in less matches (eg. if 2 out of 3 are needed and 3 out of 4 as well, then adding a stopword will decrease result set).

I think removing stopwords from the list should fix your symptoms. Did you reindex the whole content after changing the list?

 

Thanks for your answer gaetano.

Is it possible to modify this rule ?

Yes i already tried to remove the stopwords and reindexing the content it still doesn't work.

Tuesday 08 October 2013 12:37:31 pm

Also when i remove this parameter from the search query it works well. But some attributes doesn't show. 

http://pastebin.com/SBFc3Jq7

I thinks that this qf it's all the searchable attributes ?

Modified on Tuesday 08 October 2013 12:41:04 pm by Guillaume Kempfer

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from