eZ Community » Forums » Extensions » MultiUpload - After uploading first...
expandshrink

MultiUpload - After uploading first file client session gone (eZ 4.2.0)

MultiUpload - After uploading first file client session gone (eZ 4.2.0)

Tuesday 30 August 2011 6:55:17 pm - 3 replies

It used to work but since I moved to another server I have this error.

So when uploading multiple files after the first file has been uploaded it seems the session of the user gets destroyed or something. The files get uploaded because I can see them in the preview screen. But only the first file really gets added to the system.

When the uploader shows the "All files received." message I click on the folder where I uploaded the files and them i get forward to the log in screen.

When I check the active session of the user in another browser I see that the session on the server is still valid because it's still visible in Session Management.

I am using the default multiupload extension that comes with eZ Publish 4.2.0. I am working from the admin interface.

Tuesday 06 September 2011 10:55:59 am

Hmmm nobody knows anything about this issue?

Tuesday 06 September 2011 2:02:30 pm

Do you use suhosin patch/extension with PHP? If so, try to disable it. If from some reason you cannot do so, try if multiupload works with  suhosin.session.encrypt setting disabled

Tuesday 06 September 2011 3:16:27 pm

Hi Jeroen,

I'm working on a very similar case, so I hope we can help each other. Some notes and questions:

  • When you get logged out, the session is not valid anymore. Depending on PHP versions/patches, it may still exist in the database, and be visible in Session Management, until you run the session garbage collector cronjob (cronjobs/session_gc.php).
  • Could you please show us what's in the ezsession table for this user, when this happens?
  • As Jarosław says, if you can't disable Suhosin, at least make sure that suhosin.session.encrypt is disabled.
  • site.ini [Session] SessionValidationUseUA should be disabled, please check this.
  • php.ini session.auto_start should be disabled (I mean the PHP settings file, not an eZ Publish settings file).
  • What are your site.ini [Session] settings? It could be helpful if you shared the entire section.
  • Is the site clustered? What kind of cluster?
expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from