This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Extensions » OE 5.0 eZ Publish 4.1.0 -eZ Flow...
expandshrink

OE 5.0 eZ Publish 4.1.0 -eZ Flow doesn´t show any icons

OE 5.0 eZ Publish 4.1.0 -eZ Flow doesn´t show any icons

Sunday 26 April 2009 3:50:23 pm - 6 replies

Hi!

As i mentioned before, this are my first steps in eZ Publish 4.1.0. Have Installed it with eZ Flow.
After installation, I only get Disable editor button when editing content, and the text 'advanced.block' where the editor should be.

The editor doesn´t show any icons, did following checks:
- ActiveExtensions[]=ezoe
- old Online Editor (ezdhtml) is not also enabled
- checked installation path
- run ezpgenerateautoloads.php
- made sure to have cleared all the caches (both eZ Publish and browser).
- Enabled debug output, but don´t know what to show for

This is my .htaccess:
# Copy this file to a new file called .htaccess in your eZ Publish root
# to make the site more secure in non-virtualhost mode (index.php used in urls).
#

<FilesMatch ".">
order allow,deny
deny from all
</FilesMatch>

<FilesMatch "(^index\.php|favicon\.ico|index_treemenu\.php|\.(gif|jpe?g?|png|css|js|swf|html?)|var(.+)storage.pdf(.+)\.pdf)$">
order allow,deny
allow from all
</FilesMatch>

# If you see "Forbidden" when trying to access root page of your site
# without 'index.php' appended, uncomment the following "Files" section.
# NOTE: replace "ezpublish-4.1.0" with base name of the directory
# where your eZ Publish intallation resides.
# e.g. base name of "/sites/ezpublish/ezpublish-4.1.0" is "ezpublish-4.1.0".

#<Files "ezpublish-4.1.0">
# order allow,deny
# allow from all
#</Files>

RewriteEngine On

# Allow access to the index_treemenu.php file for a faster admin interface
RewriteRule content/treemenu/? index_treemenu.php
RewriteRule ^index_treemenu\.php - [L]

# Uncomment the line below if you placed your favicon at the root of your
# eZ Publish instance. It will then be served directly.
#RewriteRule ^favicon\.ico - [L]
# Uncomment the line below if you want you favicon be served from the standard design.
# You can customize the path to favicon.ico by replacing design/standard/images/favicon.ico
# by the adequate path.
#RewriteRule ^favicon.ico design/standard/images/favicon.ico [L]
RewriteRule ^design/standard/images/favicon\.ico - [L]

# Uncomment the line below once you set up the right robots.txt file
# In that case remember to also modify the FilesMatch rule abov
# More info here http://en.wikipedia.org/wiki/Robots.txt
#RewriteRule ^robots\.txt - [L]

# Uncomment the line below in case you are using
# Platform for Privacy Preferences Project ( P3P ) related files.
# In that case remember to also modify the FilesMatch rule above
# More info here : http://en.wikipedia.org/wiki/P3p
#RewriteRule ^p3p/(.+)\.xml - [L]

RewriteRule !(\.(gif|jpe?g?|png|css|js|swf|html?)|var(.+)storage.pdf(.+)\.pdf)$ index.php
RewriteRule ^/var/[^/]+/cache/public/.* - [L]

DirectoryIndex index.php

THX for help

Cris

Modified on Sunday 26 April 2009 3:51:11 pm by Cristian Solderer

Sunday 26 April 2009 4:37:29 pm

You seesm to have a pretty custom .htaccess, but try to switch the order of the last rules:

RewriteRule !(\.(gif|jpe?g?|png|css|js|swf|html?)|var(.+)storage.pdf(.+)\.pdf)$ index.php
RewriteRule ^/var/[^/]+/cache/public/.* - [L]

It not have a look in the faq (see the one in svn as it is more up to date until 5.0.1 is out):
http://svn.ez.no/svn/extensions/eztinymce/trunk/ezoe/FAQ

Other then that, check what path ezoe treies to load cached js / css from and open up in browser to see if you get apache error or eZ Publish error when you instead should simply get a file.

Or if your lazy or don't have time to debug, enable DevelopmentMode in ezoe.ini.

Monday 27 April 2009 7:17:51 pm

Thanks for help. The OE is working, but I don´t know which step it was to mak it work.
Regards
Cris

Monday 01 June 2009 2:42:53 pm

Hi!
Hav installed a 4.1.2 with the same options like before. The Online editor doesn´t appear.
Could someone give me a hint or have a look on my instance?
would like to write a mini-documentation for further installations.
thanks
cristian

Monday 01 June 2009 3:40:32 pm

It may be the cache directory rewrite.

Try changing the cache rule to:

RewriteRule ^/var/([^/]+/)?cache/public/.* - [L]

Paul

Monday 01 June 2009 5:52:46 pm

hi paul!
it didn´t work.
could it be that some folders ore files have the wrong permissions?
thanks
cristian

Monday 01 June 2009 6:01:45 pm

Ok, try this.

In extension/ezoe/settings/ezoe.ini change DevelopmentMode to be enabled. Clear the cache and try again. The dev mode should tell you if its a rewrite problem. If the OE works its a rewrite issue.

Paul

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from