eZ Community » Forums » Extensions » RedirectOperators on EZ 4.5
expandshrink

RedirectOperators on EZ 4.5

RedirectOperators on EZ 4.5

Monday 26 September 2011 6:30:49 pm - 8 replies

Hello,

I'm trying to make RedirectOperators work on EZ 4.5 (I know I should not use them... sorry) but I have an internal server error each time the operators are executed.

Do you have any idea ?

Monday 26 September 2011 7:19:34 pm

Hello Franck,

I'm not certain the problem... a few thoughts.

- Have your reviewed your web server logs for php errors?

- Have you enabled php.ini setting display_errors ?

- Did you remember to regenerate autoloads?

- What error exactly are your getting?

 

Cheers,

Heath

Tuesday 27 September 2011 9:52:39 am

Hello,

  • autoloads are regenerated
  • I display all PHP errors but don't get any
  • Nothing logged in error.log of my Apache server
  • I get an internal server error (error 500) from Apache

Tuesday 27 September 2011 5:38:12 pm

Have you tried:

http://projects.ez.no/redirect_operators

Wednesday 28 September 2011 10:06:14 am

This topic is all about Redirect Operators (http://projects.ez.no/redirect_operators).

Wednesday 28 September 2011 10:32:51 am

This topic is all about Redirect Operators (http://projects.ez.no/redirect_operators).

Oh sorry, my bad, I misread and I thought you wanted to created your own operator that's why I suggested that link.

Wednesday 28 September 2011 11:01:32 am

on community 4.5 I've managed to have it worked doing this:

  1. edit extension/RedirectOperators/settings/site.ini.append and add a trailing slash '/' to the AutoloadPathList value => extension/RedirectOperators/autoloads/
  2. edit extension/RedirectOperators/autoloads/redirectoperators.php replace all occurrence of 'exit();' by 'eZExecution::cleanExit();'

The first point was generating an error in the debug saying it couldn't find the class.

The second point is generating a Fatal Error.

I've not encountered any error 500 though...

Wednesday 28 September 2011 11:31:19 am

It works. Thanks.

Sunday 18 November 2012 8:06:27 pm

Thank you Huy,

I also stumbled upon this doing an Update right now.

By the way, there is a GitHub for this by now: https://github.com/gbentley/redirectoperators

This includes both fixes.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from