eZ Community » Forums » Extensions » Solr installed and working, eZFind...
expandshrink

Solr installed and working, eZFind enabled but no search results

Solr installed and working, eZFind enabled but no search results

Tuesday 14 February 2012 6:26:44 am - 9 replies

Hey,
I'm running ezpublish 4.5, ezfind 2.3 and JRE 6.

I have Solr installed, setup as a service and running. I can index the site and it says I have 77 items indexed. I can access http://127.0.0.1:8983  and perform searches across the indexed items and I get results. I have the ezfind extension enabled in my admin siteaccess' site.ini.append.php

But, I get no search result when performing a search in both my admin siteaccess and my default siteaccess.

I have a ezfind.ini.append.php file setting the 'DefaultSearchHandler' to 'ezpublish'

Does anyone have any suggestion on how I fix this?

Thanks in advance,

Josh

Modified on Tuesday 14 February 2012 6:28:21 am by Josh Millard

Tuesday 14 February 2012 9:18:23 am

Hi Josh,

 

Check two points before trying something else:

On http://localhost:8983/solr/admin/stats.jsp check number of docs. If its not egal as 0 try to change DefaultSearchHandler to standard.

You could check solr.log to see if something its not wrong too (extension/ezfind/java/logs/)

 

Philippe

Tuesday 14 February 2012 10:34:41 am

Be sure that the content is indexed for the correct language and that you use an frontend with this language

Tuesday 14 February 2012 12:51:17 pm

HI Josh,
You can also check permissions on the folder 'extension/ezfind/java/{logs,solr}'.

Web server must be the owner.

Tuesday 14 February 2012 9:32:59 pm

Hi Josh,

make sure that site.ini/[SearchSettings]/SearchEngine has the value of "ezsolr", maybe some of your settings override that.

You should also take a look at the debug output on the page and in the logs (particulary error logs) to see if there's any relevant info in there. At last, if nothing helps, try performing in Solr admin the same Solr requests eZ generates and see what happens (they should be in the debug output).

Wednesday 15 February 2012 5:12:52 am

Firstly, Sorry Edi, I accidentally clicked the "Inapproriate" button instead of the "Reply" button....I'm an idiot..sorry! I'm not sure how to un-flag it.

Thanks for all your replys guys.

Philippe, I checked the Solr status and it shows 78 docs. I also tried switching the DefaultSearchHandler to standard but it still didn't work. There was also nothing helpful in the logs.

Marc, I've set the "DefaultCore" to "eng-AU" under "LanguageSearch" in my ezfind.ini.append.php file. Which is the same language as the default for my site.

Sébastien, The permissions seem to be fine for these two directories because there is data in the /index/ directory and contents in the log files.

Edi, The "SearchEngine" setting is set to "ezsolr". I can get search results performing a query directly in the Solr admin page.

If I disable the ezfind extension, search works again in the admin site access, but as soon as I enable the ezfind extension, i get zero search results.

 

Thanks again for all your help guys!

Wednesday 15 February 2012 9:31:37 am

I'm going to guess that it's a problem with the template fetch at this point that is returning 0 results... try and do the most generic search possible amd see if something comes back.

Otherwise, is maybe the ezfind.ini [FacetSettings]SiteNameList[] setting wrong? Or maybe solr.ini [SolrBase]SearchServerURI?

Friday 17 February 2012 1:17:42 am

Hey Steven,

I've tried multiple searches, even as simple as "a". I'm testing using the admin page's top right search box.

I didn't have anything set in the [FacetSetting] SiteNameList setting, but now I've tried adding the value from the "ezsite_data" table as the SiteNameIndex and my domain as the value. Still no results.

The [SolrBase] SearchServerURI is set to the default "http://localhost:8983/solr"

Each time I've been testing these settings changes, I've been restarting Solr and re-indexing the site, and clearing all cache.

Thanks for your suggestions.

Friday 17 February 2012 1:21:34 am

I'm getting these lines in the debug log along with the details of the query that is being sent to Solr.

[ Feb 17 2012 10:48:49 ] [10.1.1.22] ezpI18n::translateText:Missing translation for message in context: 'ezfind'. The untranslated message is: 'Server not running'
[ Feb 17 2012 10:48:49 ] [10.1.1.22] Timing Point: Module end 'content'
[ Feb 17 2012 10:48:49 ] [10.1.1.22] ezpI18n::translateText:Missing translation for message in context: 'kernel/navigationpart' with comment: 'Navigation part'. The untranslated message is: 'eZFind'
[ Feb 17 2012 10:48:49 ] [10.1.1.22] ezpI18n::translateText:Missing translation for message in context: 'kernel/navigationpart' with comment: 'Navigation part'. The untranslated message is: 'Service portal'

I read in another post these weren't of concern, is that correct?

Tuesday 20 March 2012 5:05:17 pm

A bit late, but anyway hope is useful to anyone - if you are using the default admin2 design, you should check your templates/content/search.tpl file, because it is actually using content-fetch instead of ezfind-fetch - at least it was the issue for me, when I got this problem (actually in my case I had working frontend search with my custom search templates, and non-working backend with default templates). You just need to do override for search.tpl and advancedsearch.tpl templates for admin to use the correct fetches, and your search will work I hope.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from