This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Extensions » Sqliimport in fuji (4.4)
expandshrink

Sqliimport in fuji (4.4)

Sqliimport in fuji (4.4)

Tuesday 22 March 2011 10:34:43 am - 9 replies

Hi!
Has anyone been able to run sqliimport in fuji/4.4?
I uploaded a fresh copy of sqliimport 1.2.0 and then entered the admin interface and tried to activate it. I then got this error:
"Class eZPendingActions in file extension/sqliimport/classes/ezpendingactions.php is already defined in: kernel/classes/ezpendingactions.php (autoload/ezp_kernel.php)
This class was not added to the autoload array."
According to this link; http://bit.ly/cZO2NG this is "No big deal". But I wasn't able to find out to fix this, so I deleted ezpendingactions.php from the extension. As it is already a part of eZ, and should therefore be redundant.
I then emptied all caches, generated atoload-arrays, and tried the activation again. I now got to errors in eZ debug:Error:
eZINI::save
Failed opening file 'settings/override/site.ini.append.php.tmp' for writing
Error: eZExtension::activeExtensions
Extension 'ezwt' does not exist, looked for directory 'extension/ezwt'
And now I'm stumped happy.gif Emoticon
Does anyone have any advice on how to get sqliimport up and running in 4.4?

Tuesday 22 March 2011 11:14:45 am

Hello Peder

I have SQLIImport up and running on a fresh Fuji installation. The warning you have when you regenerate autoloads is because I backported eZPendingActions class from Fuji to be used in previous eZ Publish versions. I'll remove this class in a future version and propose it as a separate download.

Your other errors don't seem to be related to SQLIImport but to other extensions issues. Instead of activating extensions from the admin interface, try to activate manually from your site.ini.append.php file blunk.gif Emoticon

And by the way, you should take the latest SVN version from trunk (1.2.1) as several issues are fixed in it and I didn't have time to package a new version.

Tuesday 22 March 2011 12:17:00 pm

Ah, manually activating from site.ini.append.php worked like a charm!

Thank you happy.gif Emoticon

Modified on Monday 04 April 2011 10:00:22 am by P. Dukefos

Monday 04 April 2011 10:23:23 am

Hello again,

I've gotten a bit further, but now I've stumbled on another question: How do I send parameters and/or variables into SQLIimport?

E.g. I have a php-file that fetches the nodeID for the object I want to update. And want to send that ID into $content = SQLIContent::fromNodeID($myFetchedNodeID); in my handler.

I've tried adding it through php $_post, $_get and in the call for the handler, i.e. "php extension/sqliimport/bin/php/sqlidoimport.php --source-handlers=myHandler --options="myHandler::myFetchedNodeID=357"
"

But, alas to no avail so far. Any tips?

Monday 04 April 2011 11:41:22 am

Hello Peder

Options are passed to your handler's constructor as an SQLIImportHandlerOptions object. This object is iterable and you can access to your options this way :

$myOption = $handlerOptions->optionName; // $handlerOptions is an SQLIImportHandlerOptions object
 
// Object is iterable
foreach ( $handlerOptions as $optionName => $optionValue )
{
    echo "Option name is : $optionName\n";
    echo "Option value is : $optionValue";
}

Thursday 06 October 2011 12:58:52 pm

Hi Jerome,

I have the same problem with an eZ Publish 4.5 install. Git cloned the extension from github to the extension folder, activated it via admin, but got the ezpendingactions.php error. Deactivated it, and activated it by hand in settings/override/site.ini.append.php - didn't help. I'm still getting the "requested page could not be displayed. (20)" error in sqliimport/list.

Any other hints?

Jens

Thursday 06 October 2011 1:31:17 pm

Hi Jens

You can safely remove the ezpendingactions.php from SQLIImport classes folder.

Did you clear your caches ?

Thursday 06 October 2011 2:31:40 pm

yes, I tried both, deleting ezpendingactions and clearing caches, didn't help.

What did the job was renaming the SQLIImport folder to sqliimport.

Thanks anyway for your answer, Jerome. Great extension!

Friday 07 October 2011 10:31:52 am

What did the job was renaming the SQLIImport folder to sqliimport.

Oh I see... This happened because you directly cloned from Github, right ?

Thanks anyway for your answer, Jerome. Great extension!

You're very welcome happy.gif Emoticon

Thursday 24 November 2011 11:27:35 pm

Hi,

I got the same issue with the inexact eZExtension::activeExtensions error.

For me, the extension dir was actually a symlynk to another dir, owned by another user.

Onced logged in www-data (yep, debian apache user), I've seen that my link was'nt good for www-data even if appears correct when logged with my first user.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from