eZ Community » Forums » Extensions » Translations not loading in extension
expandshrink

Translations not loading in extension

Translations not loading in extension

Monday 19 March 2012 12:28:38 pm - 2 replies

I'm having trouble getting the translations to load in a custom extension on a 4.0.7-installation. In my extension site.ini:

 [RegionalSettings]
TranslationExtensions[]=<em>myextension</em>

Every string in the templates are translated with:

 {'My string'|i18n('context')}

And in PHP:

 ezi18n("context", "My string");

And this is error when enabling debug output:

Missing translation for message in context: 'lib/template'. The untranslated message is: 'The maximum nesting level of %max has been reached. The execution is stopped to avoid infinite recursion.'

This error doesn't make any sense to me. I've already spent several hours trying to debug, and making sure that the settings and translations strings are correct. Any help would be deeply appreciated!

 

 

Wednesday 28 March 2012 11:15:47 am

Hello,

 

2 things get in my mind :

could you go to the administration panel , in the configuration.ini view to see if your extension  is in the list of the translation part ( choose your backsiteaccess and site.ini file).

then  there is a blank before [RegionalSettings] in your code : is it when you write in the forum or in your file too ?

let us know , we will try to help you .

Alexandre

Tuesday 24 April 2012 10:52:02 am

Hi,

  • First check if your extension is active under active extensions.
  • Second regenerate autoloads
  • Third checke permissions
  • Try to set it also in your override/site.ini.
  • Check if your translation is in your extension, and the translation files are there.
  • Check if the translation files are name well

Let me know if all of this is set.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from