eZ Community » Forums » eZ Publish 5 Platform » A Token was not found in the...
expandshrink

A Token was not found in the SecurityContext

A Token was not found in the SecurityContext

Thursday 04 July 2013 11:31:39 am - 7 replies

I'm currently trying to upgrade a site from 4.7.0 to 5.1.0. After running the upgradescripts from the documentation I get this error when accessing any siteaccess: "A Token was not found in the SecurityContext", "500 Internal Server Error - AuthenticationCredentialsNotFoundException".

When i edit security.yml and added security:false to ezpublish_front i was able to access the frontsiteaccess just fine, but when trying to login from the admin siteaccess the page just "reloads" without any messages and clears the inputfields.

For what it matters, I got a 5.1.0 installation of another site on the same server, whos also been upgraded from 4.7.0, which I didn't experience any problems upgrading.

Any idea, guys?

Monday 08 July 2013 3:41:47 pm

Hey Harald,

 maybe it has to deal with the eZ - extension 'ezformtoken'. Once upon a time I had a similar Problem and went mad until I figuret out what the Problem was. No implementation of formtokens in a specific Extension blunk.gif Emoticon

Maybe it helps you.

 

Cheers Chris

Tuesday 09 July 2013 10:08:18 am

Hello, and thanks for you reply.

eZformtoken extension wasnt enabled in legacy. I tried enabling it, but didnt make any difference.

What do you mean by "No implementation of formtokens in a specific Extension"?

Wednesday 10 July 2013 4:00:33 pm

Hey Harald,

 you got me completely right. With specific extension i meant a custom-built extension. Unfortunately it does not solve your problem sad.gif Emoticon 

Could you imagine migrating your stuff from your eZP 4.7 to a fresh 5.1 ? Maybe that leads earlier to a joyful result, but is not cutting edge. 

Cheers Chris 

Wednesday 11 September 2013 10:26:28 am

Hi

Harald, did you try to re-generate autoloads in legacy?

Wednesday 11 September 2013 10:43:14 am

Hi Jerome.

Sorry for not following up the thread. This was caused by a mistake in my virtualhost setup, that caused a htaccess file to execute.

I had (for some unknown reason) not enabled AllowOverride None in my virtualhost, even though its stated in the doc.

-Harald

Wednesday 11 September 2013 10:48:25 am

Thanks for the update. Did you find out which clause in your .htaccess file was the origin of your problem ? Could be interesting for the community knowledge base blunk.gif Emoticon

Wednesday 11 September 2013 10:53:58 am

Quote from Jérôme Vieilledent :

Thanks for the update. Did you find out which clause in your .htaccess file was the origin of your problem ? Could be interesting for the community knowledge base blunk.gif Emoticon

No, sorry, I never investigated it any further once I found my misstake.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from