This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » eZ Publish 5 Platform » Adding new siteaccess
expandshrink

Adding new siteaccess

Adding new siteaccess

Thursday 13 December 2012 9:35:00 am - 13 replies

Hello

I'm now working on eZ 5.0 and i did not manage to add a siteaccess using yml configuration (/app/config/ezpublish.yml)

Exacty i added an ''public' siteaccess in ezpublish:siteaccess:list part and added it in the ezpublish:siteaccess:groups:ezdemo_site_group part

Do we need to modify legacy site.ini, or did I made some mistakes ?

Thanks in advance

Thursday 13 December 2012 9:47:02 am

Hi Jonathan

Given that you're talking about app/ folder, I assume that you're working with 2012.9, which is completely outdated now. You should consider either waiting for the next CP version, which should be there by the end of the week, or working directly from Git.

Secondly, are you starting a project from scratch or is it a migration ? I mean, does your new siteaccess depend on legacy settings (like override rules) ? If so, yes you will need to reflect your legacy site.ini override.

Thursday 13 December 2012 9:53:25 am

Hi Jerome

Sorry it's a mistake, i would mean /ezpublish/config/ezpublish.yml.

I started from strach, installing directy the 5.0 version (from Partner portal)

Thursday 13 December 2012 10:07:29 am

OK fine then happy.gif Emoticon.

But what are you trying to do exactly ? Matching a new siteaccess ? Can you please show your config file (ideally from a gist) ?

Thursday 13 December 2012 10:30:36 am

Here my configuration :

https://gist.github.com/4f0cb951ef072c853a1c

Thursday 13 December 2012 10:40:24 am

OK. And what is the issue you have exactly ?

Thursday 13 December 2012 11:14:29 am

While trying the following url web/public/Mes-actus , i was redirect to back office login form.

I think that i need some policies to be able to see the public siteaccess.

So i wanted to add the right policies to the anonymous user, but the siteaccess is not visible in the back office.

Thursday 13 December 2012 11:33:41 am

Quote from Jonathan Hurtrel :

While trying the following url web/public/Mes-actus , i was redirect to back office login form.

I think that web/ should be removed blunk.gif Emoticon.

Thursday 13 December 2012 11:39:29 am

For the moment, i haven't done any redirections for removing web/ .

Others url like web/Mes-actus or /web/ezdemo_site_admin/Mes-actus works fine

Thursday 13 December 2012 11:50:35 am

Are you pointing to a virtual host or simply accessing through folders from your webroot ? Anyway you should at least specify the front controller here (index_dev.php if in dev mode) blunk.gif Emoticon.

Try to configure everything in legacy (e.g. design fallbacks). Then in admin, don't forget to grant anonymous user the right to login on your public siteaccess.

Thursday 13 December 2012 12:29:54 pm

I'm accessing through folders. Anyway i have added the RewriteRule .* index_dev.php in my .htaccess. For the moment it is simpliest becaues my developments are only for learning ez 5.

I have created the siteaccess in legacy mode (based on eng siteaccess parameters, site.ini added in the gist).

The siteaccess works fine now on the homepage, but not while trying to access another page (/mes-actus or /City-Shopping), i'm getting an "Module not found error"

 

During our discutions I have changed the ezpublish.yml to fit more my needs: https://gist.github.com/4f0cb951ef072c853a1c

Thursday 13 December 2012 12:37:45 pm

I just tried accessing via /ezpublish_5_0/web/fre/content/location/87, and i get an ezpContentNotFoundException (error 500), which work while trying with an another site access in url (eng)

Thursday 13 December 2012 12:43:03 pm

Jonathan: I think you need to also specify the siteaccess in site.ini settings so your able to grant anonymous access to the siteaccess in admin interface.

 

Jérôme: This might hint that we are not injecting the siteaccess list or related siteaccess list setting.

Modified on Thursday 13 December 2012 12:50:02 pm by André R

Thursday 13 December 2012 2:11:34 pm

In the site.ini (override), the Siteaccess has already been added as following :

[SiteSettings]

DefaultAccess=eng

SiteList[]

SiteList[]=ezdemo_site

SiteList[]=eng

SiteList[]=ezdemo_site_admin

SiteList[]=fre

 

[SiteAccessSettings]

AvailableSiteAccessList[]

AvailableSiteAccessList[]=ezdemo_site

AvailableSiteAccessList[]=eng

AvailableSiteAccessList[]=ezdemo_site_admin

AvailableSiteAccessList[]=fre

 

Moreover, the policy user/login is granted to anonymous role for the fre siteaccess

Modified on Thursday 13 December 2012 2:12:17 pm by Jonathan Hurtrel

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from