This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » eZ Publish 5 Platform » Assetic Controller
expandshrink

Assetic Controller

Assetic Controller

Tuesday 11 November 2014 1:17:54 pm - 3 replies

Tried to activate the assetic controller in dev environment for 2 projects.

In config_dev.yml

assetic:

use_controller: true

 

When I delete the web/css folder and clear the cache I expect that the assets are loaded through the assetic controller and are therefore dynamically handled (faster development without assetic:dump after every change).

But the result is a 404, only if I dump the assets again via assetic:dump everything is loaded fine.

 

Setup:

ezpublish 2014.7

symfony 2.3.21

 

Tried with an plain symfony 2.3.21 app and there everything works like expected.

Also opened a jira issue: https://jira.ez.no/browse/EZP-23619

Tuesday 11 November 2014 2:16:49 pm

Hi, did you adjust the rewrite rules for this?

Latest Virtual Host version does this automatic, but the doc did not include this until a week ago, and .htaccess is not updated for doing this automatically yet.

The part in .htaccess that needs to be disabled is:

# Additional Assetic rules for eZ Publish 5.1 / 2013.4 and higher:
## Don't forget to run php ezpublish/console assetic:dump --env=prod
## and make sure to comment these out in dev environment.
RewriteRule ^css/.*\.css - [L]RewriteRule ^js/.*\.js - [L]

Modified on Tuesday 11 November 2014 2:20:10 pm by André R

Tuesday 11 November 2014 3:59:09 pm

Hi. Had some similar problems in the past, but all goes as expected after applying the vhost template that you can find in github repo

Tuesday 11 November 2014 4:01:21 pm

Nice that worked.

 

Thank you happy.gif Emoticon

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from