eZ Community » Forums » eZ Publish 5 Platform » Avoid browser cache not refresh on...
expandshrink

Avoid browser cache not refresh on page load

Avoid browser cache not refresh on page load

Thursday 02 July 2015 12:51:16 pm - 2 replies

Hi,

Have a problem when using front-end editing. After the editor has published content (lets say an article), and goes back to the lists for articles - the article doesn not appear in the list. Or the editor edits content, and goes back to the page - the changes are not visible. But if we run an hard refresh, the changes are visible.

The purging of Varnish works perfeclty, but it seems like the browser caching is a bit heavy. Is there a way to not use browser caching, and just use Varnish cache? Or maybe a other solution to this issue.

Best regards,

Anders Berre

Thursday 02 July 2015 11:39:08 pm

Actually taught browser caching was disabled by default, have you enabled ttl cache or are you setting any specific cache headers? Or maybe you need to reset cache headers on Varnish side to make sure it is not cached on client?

Tuesday 07 July 2015 2:37:06 pm

Quote from André R :

Actually taught browser caching was disabled by default, have you enabled ttl cache or are you setting any specific cache headers? Or maybe you need to reset cache headers on Varnish side to make sure it is not cached on client?

Can it seriously be so stupid easy. This one: ttl_cache: true under group: content?

Had some serious issues with cache not lived long enough, so tried different settings. After turning this on it looked like it worked nice.

Will try to turn this one of, and see what happens.

Thanks!

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from