eZ Community » Forums » eZ Publish 5 Platform » Bug when creating url alias?
expandshrink

Bug when creating url alias?

Bug when creating url alias?

Monday 19 August 2013 11:07:29 pm - 10 replies

Hello.

When creating a url alias in the eZ Backend, for example /Search for the module /content/search, calling the Url /Search causes a Symfony exception

Notice: Undefined property: Symfony\Bundle\FrameworkBundle\HttpKernel::$renderer in /srv/www/htdocs/vendor/symfony/symfony/src/Symfony/Bundle/FrameworkBundle/HttpKernel.php line 76

Is it a known bug? My version is 2013.6.

 

Regards

Kostas

Tuesday 20 August 2013 5:59:49 pm

Hi

Can you please provide the whole stack trace (with Xdebug) ?

Thanks

Thursday 22 August 2013 11:37:16 am

Hi Jérôme and sorry for the delay,

 

so here is the stack trace.

 

Regards Kostas

 

 
Stack Trace

    in /srv/www/htdocs/vendor/symfony/symfony/src/Symfony/Bundle/FrameworkBundle/HttpKernel.php at line 76  -+
    at ErrorHandler ->handle ('8', 'Undefined property: Symfony\Bundle\FrameworkBundle\HttpKernel::$renderer', '/srv/www/htdocs/vendor/symfony/symfony/src/Symfony/Bundle/FrameworkBundle/HttpKernel.php', '76', array('uri' => '/content/search', 'options' => array()))
   
    in /srv/www/htdocs/vendor/symfony/symfony/src/Symfony/Bundle/FrameworkBundle/HttpKernel.php at line 76  -+
    at HttpKernel ->render ('/content/search')
    
    in /srv/www/htdocs/vendor/ezsystems/ezpublish-kernel/eZ/Bundle/EzPublishCoreBundle/EventListener/RequestEventListener.php at line 103  -+
    at RequestEventListener ->onKernelRequestForward (object(GetResponseEvent))
    at call_user_func (array(object(RequestEventListener), 'onKernelRequestForward'), object(GetResponseEvent))
    
    in /srv/www/htdocs/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/Debug/TraceableEventDispatcher.php at line 451  -+
    at TraceableEventDispatcher ->Symfony\Component\HttpKernel\Debug\{closure} (object(GetResponseEvent))
    at call_user_func (object(Closure), object(GetResponseEvent))
    
    in kernel.root_dir/cache/dev/classes.php at line 3430  -+
    at EventDispatcher ->doDispatch (array(object(Closure), object(Closure), object(Closure), object(Closure), object(Closure), object(Closure), object(Closure), object(Closure), object(Closure), object(Closure), object(Closure), object(Closure), object(Closure), object(Closure)), 'kernel.request', object(GetResponseEvent))
    
    in kernel.root_dir/cache/dev/classes.php at line 3363  -+
    at EventDispatcher ->dispatch ('kernel.request', object(GetResponseEvent))
    
    in kernel.root_dir/cache/dev/classes.php at line 3527  -+
    at ContainerAwareEventDispatcher ->dispatch ('kernel.request', object(GetResponseEvent))
    
    in /srv/www/htdocs/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/Debug/TraceableEventDispatcher.php at line 139  -+
    at TraceableEventDispatcher ->dispatch ('kernel.request', object(GetResponseEvent))
    
    in /srv/www/htdocs/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/HttpKernel.php at line 110  -+
    at HttpKernel ->handleRaw (object(Request), '1')
    
    in /srv/www/htdocs/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/HttpKernel.php at line 73  -+
    at HttpKernel ->handle (object(Request), '1', true)
    
    in /srv/www/htdocs/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/DependencyInjection/ContainerAwareHttpKernel.php at line 57  -+
    at ContainerAwareHttpKernel ->handle (object(Request), '1', true)
    
    in /srv/www/htdocs/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/Kernel.php at line 199  -+
    at Kernel ->handle (object(Request))
    
    in /srv/www/htdocs/web/index.php at line 59  -+
    at require ('/srv/www/htdocs/web/index.php')
    
    in /srv/www/htdocs/web/index_dev.php at line 3  -+

Tuesday 27 August 2013 3:36:33 pm

Hello,

so did anyone have the same problem? I did not change anything at the configuration, so this should be the standard url alias handling.

 

Regards

Kostas

Thursday 03 October 2013 3:26:34 pm

Hello,

Same bug here, but not exactly the same error (2013.7):

Modified on Thursday 03 October 2013 3:35:03 pm by Romain Bremaud

Friday 04 October 2013 10:31:41 am

Hi

Can you please report an issue on Jira and paste the link here ?

Thanks happy.gif Emoticon

Friday 04 October 2013 11:58:52 am

Hi Jérôme, Konstantinos,

Bug create on Jira

Friday 04 October 2013 12:10:42 pm

Thanks Romain !

Friday 04 October 2013 6:10:59 pm

Pull-request: https://github.com/ezsystems/ezpublish-kernel/pull/542 

Can you please test it and report your feedback on the pull-request itself ? Thanks.

Saturday 05 October 2013 3:21:18 pm

Fixed in master: https://github.com/ezsystems/ezpublish-kernel-ee/commit/7173fcb

Thanks for reporting !

Monday 07 October 2013 3:48:02 pm

Thanks Jerome, 

It's works for me. Thanks for the rapidity.

Romain

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from