eZ Community » Forums » eZ Publish 5 Platform » Can't install legacy bridge due...
expandshrink

Can't install legacy bridge due dependencies problem

Can't install legacy bridge due dependencies problem

Friday 22 May 2015 8:20:07 pm - 10 replies

Hi. i'm trying to install legacy on top of ezplatform but having a problem of dependencies. here's what i get

Followed the instructions given in confluence. Any one experiencing the same? 

Thanks. 

Friday 22 May 2015 8:30:38 pm

Are you using master?  I had just run into this.

You have to make sure you are on the v0.7.0 tag and the correct dependencies will match.

Friday 22 May 2015 9:56:11 pm

You mean 0.7.0 of legacy brige or?

Friday 22 May 2015 10:09:17 pm

The reply has been removed because of violation of forum rules.

Friday 22 May 2015 10:13:42 pm

Damn, sorry Douglash, i accidentally marked your Reply as innapropiate..Sorry. You said ezplatform v0.7.0. No. I installer ezplatform with composer too and with dev-máster. I'll try your suggestion. Sorry again for marking bad your Reply.

Friday 22 May 2015 10:15:06 pm

ezplatform tag v0.7.0 from github.  

Saturday 23 May 2015 3:46:59 pm

What is the composer error you are getting ?

Saturday 23 May 2015 3:51:46 pm

is in the first post of this thread.

Basically 

ezsystems/legacy-bridge v0.2.1 requires ezsystems/ezpublish-kernel ~6.0.0@alpha -> no matching package found.

Tuesday 26 May 2015 4:03:24 pm

Currently, if you use master of ezplatform you need to use master of LegacyBridge as well.

Both eZ Platform 0.7 composer.json and LegacyBridge 0.2.1composer.json requires "ezsystems/ezpublish-kernel": "~6.0.0@alpha", while their master equivalent requires master of kernel.

Maybe this is to strict, and maybe we should have a better convention for this, feedback welcome.

Tuesday 26 May 2015 4:13:55 pm

Well, my point is if you try to do a install following the extensions given here and here you get this error and it's a bit dissapointed. i tend to do the install always as i was a newcomer and always read those documents it would be great to update those docs if needed or be sure dev-version of this works with that version of that, at least for this special case. (preferred option i would say)

Modified on Tuesday 26 May 2015 4:15:26 pm by Carlos Revillo

Saturday 30 May 2015 12:34:32 am

+1 for Carlos goal here. This needs to be addressed.

Cheers,
Heath 

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from