eZ Community » Forums » eZ Publish 5 Platform » Composer create-project fails
expandshrink

Composer create-project fails

Composer create-project fails

Friday 14 November 2014 11:19:31 am - 9 replies

I can't install ezpublish community using composer.I run:

 composer create-project ezsystems/ezpublish-community

 

...and get:

 

- Installing ezsystems/ezpublish-kernel (v2014.11.4)

Downloading: 100%

[ErrorException] ZipArchive::extractTo(vendor/composer/12679239/ezsystems-ezpublish-kernel-e5698c6\eZ\Publish\Core\Repository\Tests\Service\Integration\Legacy\_fixtures\var\ezdemo_site\storage\images\design\plain-site\172-2-eng-US/eZ-Publish-Demo-Design-without-demo-content1.png): failed to open stream: No such file or directory

 

I did the same a week ago and it worked, so it seems that is a problem with new 2014.11.4 version.Could you explain what is wrong and how to fix it?

Modified on Friday 14 November 2014 12:02:56 pm by Andrey Astakhov

Monday 17 November 2014 9:53:09 am

Hi

Looks like a GitHub temporary issue. I had no problem doing the same as you.

BTW : v2014.11.5 has been tagged last friday blunk.gif Emoticon

Monday 17 November 2014 10:09:26 am

Hi

I have the same problem.

On a windows device the file path of this file is too long.

Modified on Monday 17 November 2014 10:10:13 am by Sebastian Blank

Monday 17 November 2014 1:45:45 pm

Quote from Sebastian Blank :

On a windows device the file path of this file is too long.

Yes, I've also found out that it happens only on Windows. 

So, @Jérôme Vieilledent, it is not temporary thing. It is rather a composer issue, but anyway it is not possible to get ezpublish-kernel using composer and it seems there is no workaround for this problem. 

Monday 17 November 2014 3:09:06 pm

Thanks for the reports, will try to fix and create a new tag with the fix.

ref: https://github.com/ezsystems/ezpu...e97b2f7c2dd0b90708ef969f5f70a51bb758

Monday 17 November 2014 6:53:29 pm

Quote from André R :

Thanks for the reports...

BTW, how is better to report about such kind of problems: here or in issues.ez.no?

Tuesday 18 November 2014 11:44:06 am

The issue was fixed yesterday, thank you for the report, @Andrey. Yes, ideally, an issue on jira.ez.no is a good move (I've created it) happy.gif Emoticon

https://github.com/ezsystems/ezpublish-kernel/pull/1094

Tuesday 18 November 2014 11:48:00 am

Can you create a new release 2014.11.6 with this change? happy.gif Emoticon

Tuesday 18 November 2014 12:17:42 pm

Done. Just cherry-picked and tagged happy.gif Emoticon

You might need to wait for a few minutes before Packagist updates

Sunday 04 January 2015 3:20:22 pm

Have you ever used LongPathTool??

It will solve your problem..

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from