This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » eZ Publish 5 Platform » Content cache problems
expandshrink

Content cache problems

Content cache problems

Monday 17 November 2014 5:57:21 pm - 4 replies

Hi,

I'm using the ezpublish version 2014.07 with the symfony2 frontend stack and I have a problems with the content cache.

Here my ezpublish.yml:

 ...
 
ezpublish:
     http_cache:
         purge_type: local
 
     system:
            front_siteaccess:
                    content:
                            view_cache: true
                            ttl_cache: true  
                            default_ttl: 30
 
...
 
stash:
    caches:
        default:
            drivers:
                - FileSystem
            inMemory: true
            registerDoctrineAdapter: false

 

When  I call findLocations($query) to get my content, the used version is never the good one.

I must clear the cache to have the right information.

If I call my query with findContent($query), it's works.

Has anybody met the same issue ?

Thanks

Modified on Tuesday 18 November 2014 9:31:39 am by Tapia André

Tuesday 18 November 2014 9:57:19 am

Hi,

 

Have you disable the viewcache in Legacy ? could be the source of problems happy.gif Emoticon

Tuesday 18 November 2014 2:14:50 pm

Hi,

Here my ezpublish_legacy/settings/override/site.ini.append.php

...
 
[OverrideSettings]
Cache=disabled
 
[ContentSettings]
ViewCaching=disabled
StaticCache=disabled
PreviewCacheUsers=disabled
PreViewCache=disabled
EditDirtyObjectAction=usecurrent
CacheTreshold=1
 
[TemplateSettings]
TemplateCompile=disabled
TemplateCache=disabled
DevelopmentMode=disabled
NodeTreeCaching=disabled

Thanks

Tuesday 18 November 2014 4:43:08 pm

Change to:

[ContentSettings]
ViewCaching=enabled

[TemplateSettings]
DevelopmentMode=enabled

As mentioned above ViewCache needs to be enabled for cache clearing to work with Symfony HTTP cache, this should have been fixed in 2014.11 by forcing this setting. For production DevelopmentMode needs to be disabled, for for development it makes sure you don't need to clear cache all the time when editing .tpl files, this works also with ViewCache enabled.

Modified on Tuesday 18 November 2014 4:44:59 pm by André R

Wednesday 19 November 2014 2:04:30 pm

thanks it's works !

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from