This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit

eZ Community » Forums » eZ Publish 5 Platform » Criterion\UrlAlias not working in ezp...

Criterion\UrlAlias not working in ezp 5.2

Criterion\UrlAlias not working in ezp 5.2

Friday 27 June 2014 8:37:53 pm

Hi Guys

Has anybody tried to fetch an content (object) using the URI for that object?

I am using the following criteria but I am getting an exception when I try to execute the query


$query = new Query();

$query->criterion = new Criterion\LogicalAnd( array(
     new Criterion\UrlAlias( Criterion\Operator::EQ, "/about"),
     new Criterion\Visibility( Criterion\Visibility::VISIBLE ),
) );
$result = $repository->getSearchService()->findContent($query);

The exception that I am getting is:

"No conversion for criterion found"

I have tried both

findContent($query) and findSingle($criterion)

on both I am getting the same exception

No reply yet!


You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from