eZ Community » Forums » eZ Publish 5 Platform » Error on login after upgrading to 5.0.0
expandshrink

Error on login after upgrading to 5.0.0

Error on login after upgrading to 5.0.0

Wednesday 22 May 2013 12:49:29 pm - 10 replies

Hello.

Im working on upgrading a site from 4.4.0 to 5.0.0 (legacy mode).

I first did an upgrade to 4.7.0, which worked excellent, but when upgrading to 5.0.0 i bumped into a major issue.

When i provide correct logininformation at the backend logininterface i get this twig error saying: 

An exception has been thrown during the rendering of a template ("Could not find 'eZ\Publish\SPI\Persistence\Content\FieldValue\Converter\*' with identifier ''"blunk.gif Emoticon in "EzPublishLegacyBundle:errors:access_denied.html.twig".

First of all, there's no folder named FieldValue in the Content folder, only a similar named file called FieldValue.php.

To be clear, I've doublechecked the user-login rights for anonymous (in the 4.7 intallation) and global rights to the admin.

Ive upgraded several sites before and never bumped into this issue.

 Any idea why im getting this error?

Wednesday 22 May 2013 12:59:38 pm

Hi Harald. First off all, it seems you're working in "non legacy mode". If you don't plan to take advantage of the symfony stack, i suggest you let "legacy_mode: true" in your ezpublish.yml for your siteaccess. 

About the error, i would say that your existing content has a datatype which haven't been ported to the new symfony stack yet. It happened to me in a similar situacion when i tried to load an "article" page. As my existing articles had a "disquscomments" datatype and this datatype has been ported to the symfony stack yet, i was getting that error. 

Anyway, eZ Crew people could have another opinion happy.gif Emoticon

Wednesday 22 May 2013 1:47:29 pm

Quote from Carlos Revillo :

Hi Harald. First off all, it seems you're working in "non legacy mode". If you don't plan to take advantage of the symfony stack, i suggest you let "legacy_mode: true" in your ezpublish.yml for your siteaccess. 

About the error, i would say that your existing content has a datatype which haven't been ported to the new symfony stack yet. It happened to me in a similar situacion when i tried to load an "article" page. As my existing articles had a "disquscomments" datatype and this datatype has been ported to the symfony stack yet, i was getting that error. 

Anyway, eZ Crew people could have another opinion happy.gif Emoticon

Thanks for the reply.

I acctually have set legacymode:true on all siteaccess' in the ezpublish.yml.

ezpublish:

system:

nor:

legacy_mode: true

ezwebin_site_admin:

legacy_mode: true

Any idea why it doesnt collect the custom datatype from the legacystack?

Wednesday 22 May 2013 1:49:00 pm

The above post was me, posting with the wrong account..

Wednesday 22 May 2013 1:58:31 pm

What you say looks quite strange to me. As far i know, that exception you are getting is comming from the new symfony stack. as far i know, having legacy_mode for all your siteaccess should make ezpublish work as before...

Wednesday 22 May 2013 3:06:07 pm

Quote from Carlos Revillo :

What you say looks quite strange to me. As far i know, that exception you are getting is comming from the new symfony stack. as far i know, having legacy_mode for all your siteaccess should make ezpublish work as before...

Yeah, thats what i though aswell. Is it possible to define legacy_mode for a siteaccessgroup?

Wednesday 22 May 2013 3:24:04 pm

I can't seem to find any doc on this atm, but what you need to do is add config for this field type and configure it as a "Null" FieldType (so it will be ignored).

The reason this is needed is because when you run true Symfony stack (no matter what legacy_mode is set to) instead of pointing Apache directly to legacy folder, authentication / session is done in Sf stack.

See here for how to configure this:
https://github.com/ezsystems/ezpublish-kernel/commit/0df61150abc589914cf7c7f1ab01c94220539126

 

Update: Doc page added now https://confluence.ez.no/display/EZP/The+Null+FieldType

Modified on Wednesday 22 May 2013 5:58:02 pm by André R

Wednesday 22 May 2013 3:27:16 pm

Quote from André R :

The reason this is needed is because when you run true Symfony stack instead of pointing Apache directly to legacy folder, authentication / session is done in Sf stack.

@Andre: So, even if you set legacy_mode: true for your siteaccess, authentication is done in Sf stack? 

Wednesday 22 May 2013 3:40:50 pm

I ran into exactly the same issue, and did a little digging.

It would appear that although running in legacy mode does utilize classes you'd be familiar with from the old kernel, you are still using the symphony stack as a wrapper, and some things run exclusively through symphony, such as certain error handling routines. 

One such error is 'page not found / module not recognized' - the handling here is done by the ez5 symphony layer without the legacy kernel getting involved. Not quite sure why eZ coded things this way, but it is what it is (at least in the version of eZ5 I was using, 5 Enterprise)

So...eZ5 running in full legacy mode will not process page error handling unless your install is also configured to function properly to run in non-legacy mode. In the end I went with the solution of creating custom fieldtypes to match my custom legacy datatypes, though there may be other ways to get round this.

Again, this may only apply to the version of eZ I'm running (5 Enterprise) and may not be an issue in later releases...maybe someone from eZ could shed some light on this?

Wednesday 22 May 2013 6:03:00 pm

legacy_mode is only to disable certain features of the eZ Publish 5.x Symfony stack (5.x stack), like url alias lookup, the rest is still on and integration still works.

Only way to use the legacy stack alone, is to point apache to it's directory, that would avoid such issues as mentioned in this thread (user class field type throwing exception, error pages handling, ..), but it will also break integration so it can't be combined with use of symfony stack.

Monday 27 May 2013 2:01:28 pm

Thanks alot for the feedback!

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from