eZ Community » Forums » eZ Publish 5 Platform » eZ Platform 15.11 does not work
expandshrink

eZ Platform 15.11 does not work

eZ Platform 15.11 does not work

Tuesday 01 December 2015 12:46:52 pm - 2 replies

I just downloaded eZ Platform 15.11 today, but found the following issues:

1. Demo bundle is gone - it was included in 2015.09.1, so that ezflow can be supported. Now, it's impossible to use ezflow.

2. It does not support ezsystems/legacy-bridge. In 2015.09.1, by patching some files, it's still possible to use legacy admin interface through the ezsystems/legacy-brdge, but it does not work this time.

3. I did a default installation (without demo bundle and ezsystems/legacy-bridge) and only installed the clean data with 'ezpublish/console platform:install clean', but there are a lot of bugs at the backoffice.

For example:

  • Editing 'Article' content type produces a 'Database error'
  • Saving changes to 'Comment' content types, produces a 'FieldDefinitions did not validate' exception
  • Can't add new attributes to content types (it just has no effect).
  • Clicking on 'cancel' button in 'Content type editing' page, does not return to previous page.
  • Changing 'user/login' policy for anonymous user, produces 'Role #1 doesn't contain any policy with ID #334' error
  • Can't create new content types (it just has no effect)

Basically, it can't be used, because its admin UI does not work and it does not support the legacy admin interface either.

The 2015.09.1 is okay, because we can at least get the legacy admin interface work by patching some files.

So did I do anything wrong or is this release really not working?

Tuesday 01 December 2015 2:58:25 pm

Hello Michael,

Thank you for your detailed report.

About demobundle, you can read about this on the weekly I've published yesterday. Another repository that includes the demo will be made public soon.

Regarding ezflow / the Page fieldtype, it is still part of the kernel. It will actually be moved to its own repository at some point, but in any case, it had never been fully supported on the new stack (the repository doesn't have write support for it).

About the legacy bridge, we are aware that some things are probably not working right now. There has been a lot of deep changes to master, and we don't officially support it. Some people on slack are interested in it, and we will accept contributions to it. What exactly went wrong when installing legacy bridge on top of 2015.11 ?

Regarding your issues, we are currently stabilizing PlatformUI, and we know that there are issues. I'm sorry to hear that you had such a bad experience, though. What I encourage you to do in the meanwhile is to upgrade to the latest tag (1.0.0-beta10), as we have hopefully fixed some of them. The others will have to be reported if they weren't already.

More in details:

  • I have edited the article content type and saved it, no errors. Did you try to edit something in particular ?
  • Same for adding Field Definitions to content types. I have added a File field def to the article content type, and it worked as expected
  • Cancel indeed sends back to the content type full view. I guess you'd expect it to be
  • About the user/login policy, I've just tried it, and didn't get an error. Fixed on master maybe (it should show up on JIRA, with a fixVersion of 2015.11.1 or 2015.11.2).
  • Same for creating a new content type, it worked without any problem here.

Modified on Tuesday 01 December 2015 3:10:27 pm by Bertrand Dunogier

Wednesday 02 December 2015 11:56:47 am

Hello Bertrand,

Thanks for your quick response and the weekly blogs are very useful.

In the meantime, I've installed 'ezsystems/demobundle' and its related bundles manually and the front office works. I have to manually configure the demobundle in the following files though:

  • ezpublish/config/config.yml
  • ezpublish/config/routing.yml
  • ezpublish/EzPublishKernel.php

As for the back office, since it does not support ezflow / page field yet, we still have to use the legacy admin interface. I've also manually installed the ezsystems/legacy-bridge and patched some files, so the legacy admin interface works on 2015.11 now.

I noticed the improvements on the new admin UI and I'm really excited about it happy.gif Emoticon The online editor eventually comes, it's does not support all the features though, but I guess it should be ready in a non-distant future.

I have been reviewing the code base for a long time and I understand how complicated it is to handle two separate systems, so I really appreciate all the hard work you guys have done and I'm really looking forward to a "pure-blood" system in the future.

Thanks for your support again.

Kind regards,

Michael

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from