This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » eZ Publish 5 Platform » eZ Publish 5 install from archive
expandshrink

eZ Publish 5 install from archive

eZ Publish 5 install from archive

Wednesday 21 November 2012 2:53:21 pm - 7 replies

Hi,
I have install the eZ Publish 5 RC1 from the archive ( I have followed the install instructions in the file "INSTALL.md" ).
But when I go to http://server/ezsetup, I have a 404 error page ( "Not found" ).
 
What could be the problem?
Thanks for your help.

Modified on Wednesday 21 November 2012 2:53:59 pm by Frederic GUEHO

Wednesday 21 November 2012 3:08:20 pm

Hi Frédéric

What is your Apache config ?

Wednesday 21 November 2012 3:29:05 pm

Hi Jérôme,

I use the "ezpublish5-5.0.0-rc1-ee-ttl.tar.gz" package from the Partner Portal (enterprise edition).

I run a debian 6 server with apache 2.2, php 5.3, mysql 5.1.
I haven't changed anything in the default apache config (in /etc/apache2/apache2.conf).

And I use a virtual host:

<VirtualHost *:80>
    ServerName myserver
    DocumentRoot /var/www/ezpublish5/web/
    <Directory /var/www/ezpublish5/>
        Options FollowSymLinks
        AllowOverride None
    </Directory>
    <IfModule mod_php5.c>
        php_admin_flag safe_mode Off
        php_admin_value register_globals 0
        php_value magic_quotes_gpc 0
        php_value magic_quotes_runtime 0
        php_value allow_call_time_pass_reference 0
    </IfModule>
    DirectoryIndex index.php
    <IfModule mod_rewrite.c>
        # Uncomment in FastCGI mode, to get basic auth working.
        #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
        # v1 rest API is on Legacy
        RewriteRule ^/api/[^/]+/v1/ /index_rest.php [L]
        # If using cluster, uncomment the following two lines:
        #RewriteRule ^/var/([^/]+/)?storage/images(-versioned)?/.* /index_cluster.php [L]
        #RewriteRule ^/var/([^/]+/)?cache/(texttoimage|public)/.* /index_cluster.php [L]
        RewriteRule ^/var/([^/]+/)?storage/images(-versioned)?/.* - [L]
        RewriteRule ^/var/([^/]+/)?cache/(texttoimage|public)/.* - [L]
        RewriteRule ^/design/[^/]+/(stylesheets|images|javascript|fonts)/.* - [L]
        RewriteRule ^/share/icons/.* - [L]
        RewriteRule ^/extension/[^/]+/design/[^/]+/(stylesheets|flash|images|lib|javascripts?)/.* - [L]
        RewriteRule ^/packages/styles/.+/(stylesheets|images|javascript)/[^/]+/.* - [L]
        RewriteRule ^/packages/styles/.+/thumbnail/.* - [L]
        RewriteRule ^/var/storage/packages/.* - [L]
       
        # Makes it possible to place your favicon at the root of your
        # eZ Publish instance. It will then be served directly.
        RewriteRule ^/favicon\.ico - [L]
        # Uncomment the line below if you want you favicon be served
        # from the standard design. You can customize the path to
        # favicon.ico by changing /design/standard/images/favicon\.ico
        #RewriteRule ^/favicon\.ico /design/standard/images/favicon.ico [L]
        RewriteRule ^/design/standard/images/favicon\.ico - [L]
        # Give direct access to robots.txt for use by crawlers (Google,
        # Bing, Spammers..)
        RewriteRule ^/robots\.txt - [L]
        # Platform for Privacy Preferences Project ( P3P ) related files
        # for Internet Explorer
        # More info here : http://en.wikipedia.org/wiki/P3p
        RewriteRule ^/w3c/p3p\.xml - [L]
        # Uncomment the following lines when using popup style debug in legacy
        #RewriteRule ^/var/([^/]+/)?cache/debug\.html.* - [L]
        # Following rule is needed to correctly display assets from eZ Publish5 / Symfony bundles
        RewriteRule ^/bundles/ - [L]
        RewriteRule .* /index.php
    </IfModule>
</VirtualHost>

I have tried <Directory /var/www/ezpublish5/> and <Directory /var/www/ezpublish5/web/> but it doesn't change anything.

Modified on Wednesday 21 November 2012 3:50:18 pm by Frederic GUEHO

Wednesday 21 November 2012 3:38:53 pm

Mmm Are you sure your virtual host is correctly activated ?

Wednesday 21 November 2012 3:41:36 pm

I certainly do.

When I go to : http://myserver/, I am redirected to http://myserver/ezsetup which is fine.
But this page give me a 404 error page ( "Not found" ). It could also be a 403 error page ( "Forbidden" ) when I refresh.

So, the virtual host is ok. if not, It would not redirect me to http://myserver/ezsetup.

And I have added a "phpinfo.php" file in the /web folder. When I go to http://myserver/phpinfo.php, it works. So, I'm sure the virtual host is activated.

Modified on Wednesday 21 November 2012 4:06:43 pm by Frederic GUEHO

Wednesday 21 November 2012 7:13:51 pm

There has been some fixes on the setup wizard recently, you can try out the code from GIT if you would like to test it before final is available for download.

Thursday 22 November 2012 12:03:38 pm

Well, I have followed this installation process from GIT :
https://github.com/ezsystems/ezpublish5/blob/master/INSTALL.md#b-from-git-development-only

And I have the exact same thing. I can access to http://myserver/ezsetup.
I have either a 403 error page or a 404 error page.

Is it normal that in the ezpublish5/web directory, there is no ./ezsetup directory ?

Modified on Thursday 22 November 2012 12:04:09 pm by Frederic GUEHO

Thursday 22 November 2012 12:50:58 pm

Well, now, it is ok. It works.

I had forgotten to change the settings of my virtual host as explained in:
https://github.com/ezsystems/ezpublish5/blob/master/INSTALL.md#b-from-git-development-only

I was using yesterday's virtual host...

Thanks

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from