eZ Community » Forums » eZ Publish 5 Platform » EzPublish5 User login Form
expandshrink

EzPublish5 User login Form

EzPublish5 User login Form

Tuesday 19 February 2013 6:15:36 pm - 2 replies

Hi !

I want to let my anonymous user log in. But I don't manage to create a loginform or use the default one.

I've created a custom siteaccess named 'customSiteAccess'. When in my ezpublish.yml, I let default_siteaccess: ezdemo_site I can access to user/login form and log but the user is connected for that ezdemo_site.

When I use  default_siteaccess: customSiteAccess, I cannot access /user/login even if I create a form login from scratch with action : "user/login"...

I don't understand exactly why it's working with ezdemo but not with mine.

in securty.yml :

 providers:        ezpublish:            id: ezpublish.security.user_provider

Maybe the question is where is going 'user/login' ?

Any ideas ?

Modified on Tuesday 19 February 2013 6:25:48 pm by Fabrice Bourgeon

Friday 22 February 2013 2:04:17 pm

Okay...

I managed to redirect to the login form of Legacy (the blue one). But when I log, my current siteaccess tell I'm still under anonymous user...So I'm logged in for site_admin but not for mine...

Is it because I go through the demo_site_admin (or legacy) form that it doesn't log me ?

Thank you

Monday 25 February 2013 2:47:52 pm

Okay

One 'ezpublish: true' was missing in the ezpublish.yml for the firewall !

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from