This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » eZ Publish 5 Platform » ezSetup does nothing
expandshrink

ezSetup does nothing

ezSetup does nothing

Wednesday 05 December 2012 4:36:12 pm - 8 replies

I am trying to install ezpublish 5 on a new server I have followed all of the instillation steps, however when I get to the ezsetup page when I click on either "finetune" or "NEXT" nothing happens. The page just seems to refresh itself. I see nothing in my apache error logs. I am using PHP 5.3.8 on SLES 11 SP2. Please help. 

 

Thanks,

Luke

Wednesday 05 December 2012 4:54:13 pm

Use the Jira, Luke!

https://jira.ez.no/browse/EZP-20196

How to fix:

a) use a correct vhost config during setup (non vhost does not seem to work on every system)

or

b) fire up firebug, and in every page of the setup wizard patch the "action" for the setup form to be .../index.php/ezsetup rather than just .../index.php. You will have to do this all the way up to the end of the setup wizard (but not later on)

Wednesday 05 December 2012 5:36:07 pm

I added my situation to the Jira (thanks didn't know about that). 

I used the VH config from http://doc.ez.no/eZ-Publish/Technical-manual/5.x/Installation/Virtual-host-setup I dont know what else would need to be added to that. 

The workaround with firebug did work however. 

Thanks,

Luke

Wednesday 05 December 2012 8:00:48 pm

Note that SLES SP2 is not supported at the moment: http://doc.ez.no/eZ-Publish/Technical-manual/5.x/Installation/Requirements

SLES SP2 issue is regarding forms, but uploading, so probably not what you have issues with; https://jira.ez.no/browse/EZP-19875

I think it is safe to assume there is a bug or two in the setup wizard in the new 5.x /ezsetup redirect code for this, it will take some time to fix it unless someone else finds it first, so for the time being workarounds are:
A. Change url using firebug on each stage
B. Point Apache to the "ezpublish_legacy" folder instead during installation, and generate yml config manually afterwards before changing Apache config back using commend described in upgrade doc: http://doc.ez.no/eZ-Publish/Upgra...ding-from-4.7-to-5.0#eztoc129581_0_7

Modified on Wednesday 05 December 2012 8:01:33 pm by André R

Wednesday 12 December 2012 8:32:53 pm

Following up on the SLES 11 SP2 - discussed with Novell support and upgraded all php components from 5.3.8-0.19.6 (default with SP2) to 5.3.8-0.33.2.  Success!

Thursday 20 December 2012 2:09:34 pm

So assuming people do have "/ezsetup" in the url, it does look like some code in ezpKernelWeb is parsing the url wrong in this case.
If anyone is able to reproduce this:

  • Make sure you have /ezsetup in url and can see the setup wizard first page
  • Check html source code and verify forms is missing /ezsetup in url:
    • Post url in the forms html source code, and what your actual url is
  • Debug ezpKernelWeb:
    • Post var_dump( $GLOBALS['eZRequestedURI']->uriString(), $GLOBALS['eZGlobalRequestURI'], eZSys::requestURI() ); from just before last $this->shutdown() in ezpKernelWeb::run()

Saturday 22 December 2012 10:02:42 am

Hi,

Just to confirm, I have the same problem, the next and finetune button not working (http://share.ez.no/forums/ez-publish-5-forum-formerly-known-as-new-php-api/ez-publish-5-install#comment78516). In the form url the /ezsetup part is missing.

Was unable to find ezpKernelWeb to do a var-dump. The workaround to change the url manually through firebug or any other webtool works.

Tuesday 16 April 2013 4:02:47 pm

Hi,

I have noted this issue.

The explanation is simpler than one expected.

The form.action URL, in HTML, is displayed via old template "welcome.tpl" ,like this :

 <form method="post" action="{$script}"

(see https://github.com/ezsystems/ezpublish-legacy/blob/master/design/standard/templates/setup/init/welcome.tpl#L18 )

The definition of this variable "$script" is done in legacy kernel file kernel/setup/ezsetup.php

 $script=eZSys::wwwDir().eZSys::indexFileName();

(see https://github.com/ezsystems/ezpublish-legacy/blob/master/kernel/setup/ezsetup.php#L148)

 

Consequently, if we use a good vhost, the form.action URL becomes empty ( $script ="" ) 

 <form method="post" action="" >

while if we do not use it, we have another URL : 

<form method="post" action="/ezp201301/web/index.php">

The former action URL tells the browser to keep the current page, which is the "ezsetup" page. The latter tells the brower to go to the "index" page.

If we want to continue, we can see that the index page is always redirected to the ezsetup page, via RequestEventListener:omg.gif EmoticonnKernelRequestSetup()   (see https://github.com/ezsystems/ezpublish-kernel/blob/master/eZ/Bundle/EzPublishCoreBundle/EventListener/RequestEventListener.php#L87 )

After that, the "ezsetup" URL is routed by routing.yml in eZ/Bundle/EzPublishLegacyBundle/Resources/config/routing.yml, and the controller method is 

LegacySetupController::init(). The legacy Kernel is ran in this controller. (https://github.com/ezsystems/ezpublish-kernel/blob/master/eZ/Bundle/EzPublishLegacyBundle/Controller/LegacySetupController.php#L103)

I have also noted that if we use the index_dev.php script to lauch the ezsetup, then the debug toolbar "_wdt" is inevitably redirected to the "ezsetup" page, ( but it is not a problem ).

I have not noted another issue with the vhost.

Thanks,

Arnaud.

Wednesday 17 April 2013 11:17:09 am

Hi, thanks for the update, it indeed sums up the problem.

I looked briefly into this a few months back and ended up with this PR:  https://github.com/ezsystems/ezpublish-legacy/pull/574

There might be better ways at fixing this, maybe injecting it as part of index name, but the code setting script parameter looks wierde to begin with.

Review's and testing of the PR is highly welcome.

Modified on Wednesday 17 April 2013 11:17:56 am by André R

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from