This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » eZ Publish 5 Platform » Hiding node without any effect
expandshrink

Hiding node without any effect

Hiding node without any effect

Sunday 08 September 2013 9:11:49 pm - 11 replies

Hi Community,

 

using Version 2013.6 und hiding a node in the backend does not have any effect on the frontend. The node is still accesible and viewable.

 

Can someone reproduce it?

 

Regards
Kostas

Tuesday 10 September 2013 1:49:28 pm

I have not seen any problems in the demo of 2013.7, so I can't tell for 2013.6.

Maybe a trivial settings problem? Check the site access site.ini for

[SiteAccessSettings]
ShowHiddenNodes=false

Tuesday 10 September 2013 5:52:47 pm

Hi Konstantinos

Are you using Public API ? If so, you must add the Visibility criterion as mentioned in Damien's Summer camp slides

Wednesday 12 February 2014 10:42:07 am

Hello

Jérôme, you're right when dealing with searches but how can we do when we use loadLocation in LocationService ? 

The default viewController of eZ is using it and thus it seems that visibility is not checked. Is that a bug ?

Wednesday 12 February 2014 11:08:15 am

When dealing with load location the controller needs to check this, so if that is not the case, then we have a bug.

Modified on Wednesday 12 February 2014 11:17:50 am by André R

Wednesday 12 February 2014 11:16:11 am

Quote from André R :

When dealing with load location the controller needs to check this, so if that is not the case, then we have a bug in demo bundle.

More annoying than DemoBundle is this controller : https://github.com/ezsystems/ezpu...oller/Content/ViewController.php#L95

Wednesday 12 February 2014 11:23:49 am

@André, maybe this could give you some hints. In my ez5 webiste, i have a list of folders under the root tree. Some of them are hidden. 

This is one of the visible ones: http://www.sillonbol.com/futbol

And this is one of the hidden ones: http://www.sillonbol.com/sillonblogs

both of them have not hidden childrens. So, in some way, it seems eZ is taking care of this visibility property, but no message is sent to the page (or probably i did something wrong). 

Wednesday 12 February 2014 11:37:06 am

Hi all

Just reported the issue : https://jira.ez.no/browse/EZP-22337 , please subscribe to it. I'll handle it ASAP.

Carlos: This doesn't affect lists, as long as you use the Visibility criterion.

Wednesday 12 February 2014 12:13:34 pm

Pull-request: https://github.com/ezsystems/ezpublish-kernel/pull/732

Thursday 27 February 2014 10:31:11 am

Does it work for you? 

No exception thrown, and my page is still displayed (2013.11). 

Modified on Thursday 27 February 2014 10:31:30 am by Nicolas Lescure

Thursday 27 February 2014 10:39:12 am

Quote from Nicolas Lescure :

Does it work for you? 

No exception thrown, and my page is still displayed (2013.11). 

It does for me. Are you using a custom controller to render your locations maybe? If so, please take in account that you will also need to add that condition as i had to do in my custom one

Thursday 27 February 2014 10:54:22 am

Good idea, it is not a custom controller. This is the standard view controller for a "view full" ("ez_content:viewLocation"blunk.gif Emoticon.

Modified on Thursday 27 February 2014 11:54:11 am by Nicolas Lescure

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from