eZ Community » Forums » eZ Publish 5 Platform » Image Alias (EZ 5.4)
expandshrink

Image Alias (EZ 5.4)

Image Alias (EZ 5.4)

Thursday 26 February 2015 4:23:05 pm - 4 replies

I am having a hard time and I feel the documentation is scattered, with no solid tutorial/steps to follow for a successful output of images, without using the legacy content view type.

I have a gallery created in the admin area, with 3 images uploaded to it (using multi upload). I use siteaccess to route the gallery type to a custom controller, where I retrieve all the children images in the gallery and have them as a variable childrenList passed to my twig template.

In twig, I want to pull in for each image a thumbnail for immediate display, and a link to the big size that would go in a popup modal, but can't figure out how to do that simple task after going through documentation. I am not sure how image Alias plays a role here, and how to pull out what I need as well.

This is from the documentation, but it complains about field, what should go there? I don't even know if this is how to do it..

https://gist.github.com/anonymous/3a022993823d176e4982

This is simply what I am after, this is just pseodocode:

https://gist.github.com/anonymous/4233be3c7f9109d89b4d

How can I get this to render out the correct src of each image, thumbnail and full size?

Modified on Thursday 26 February 2015 4:39:31 pm by Big Mike

Thursday 26 February 2015 7:24:51 pm

Hello Big Mike,

Would you be willing to write a detailed blog post on share.ez.no/blogs about the image alias system in 5.x?

In short why not follow the examples provided by the demo bundle?

https://github.com/ezsystems/Demo...ces/views/full/article.html.twig#L32

https://github.com/ezsystems/Demo...s/fields/ezimage_simple.html.twig#L1

Also are you -certain- your image alias is defined in yaml first since your using 5.4 (and sounds like not using the demobundle)?

While I do appreciate your sharing via gist(s), your not really sharing enough real code to help you troubleshoot the problem. Also you problem description of 'but it complains about field' is also not specific enough. Please be more specific in your source code examples and problem descriptions. 

I hope this helps!

Cheers,
Heath

Modified on Thursday 26 February 2015 7:25:10 pm by // Heath

Monday 02 March 2015 4:51:51 pm

Yup, It was my fault, I looped over the child locations instead of the child content.

Thanks for the pointers Heath!

Saturday 07 March 2015 2:27:47 am

Hello Big Mike,

Your very welcome! I'm happy I could help and even more happy that you found the solution!

Can you login to share.ez.no and then click the checkbox at the top of your original post near the title? It is the box with the checkbox inside. It turns green when you have clicked it correctly.

Doing this indicates your question has been solved.

Thanks again for your continued support!

Take it eZ!

Cheers,
Heath

Modified on Saturday 07 March 2015 2:28:02 am by // Heath

Monday 09 March 2015 11:39:44 am

The reply has been removed because of violation of forum rules.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from