This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » eZ Publish 5 Platform » Login problem - Ezpublish 5
expandshrink

Login problem - Ezpublish 5

Login problem - Ezpublish 5

Wednesday 16 October 2013 11:59:47 pm - 4 replies

Hi community!
I installed Ezpublish 2013.09, everything works fine except when a normal user logins (ROLE member)
Once the user login I get a 503 Service Unavailable and the error log shows this
request.CRITICAL: Exception thrown when handling an exception (eZ\Publish\Core\Base\Exceptions\NotFoundException: Could not find 'Limitation' with identifier 'ContentSection') {"exception":"[object] (eZ\\Publish\\Core\\Base\\Exceptions\\NotFoundException: Could not find 'Limitation' with identifier 'ContentSection' at /var/www/html/fanatics/vendor/ezsystems/ezpublish-kernel/eZ/Publish/Core/Repository/RoleService.php:907)"} []
Admin user works just fine!
Any help I will be highly appreciated 

Friday 18 October 2013 1:45:00 am

I had a similar problem.

I checked the roles and privileges and removed those which weren't needed, which solved the problem.

The error I received was similar to this one: https://jira.ez.no/browse/EZP-21691

I didn't report the issue because I don't have time to pursue it through to really give a good description of the problem.

Weblog user [Role]

Name: Weblog userPolicies (3)

Module

Function

Limitation

content create Class( Comment ) , Section( Standard ) , ParentClass( Weblog )
content edit Class( Comment ) , Section( Standard )
content versionread Class( Comment ) , Section( Standard ) , Owner( Self ) , Status( Draft , Pending )

Log entries:

[2013-10-14 11:33:27] app.INFO: Authentication success: PreAuthenticatedToken(user="username", authenticated=true, roles="ROLE_USER"blunk.gif Emoticon [] []
[2013-10-14 11:33:27] request.CRITICAL: Uncaught PHP Exception eZ\Publish\Core\Base\Exceptions\NotFoundException: "Could not find 'Limitation' with identifier 'Status'" at /home/account/vendor/ezsystems/ezpublish-kernel/eZ/Publish/Core/Repository/RoleService.php line 908 {"exception":"[object] (eZ\\Publish\\Core\\Base\\Exceptions\\NotFoundException: Could not find 'Limitation' with identifier 'Status' at /home/account/vendor/ezsystems/ezpublish-kernel/eZ/Publish/Core/Repository/RoleService.php:908)"} []

I think the issue is related to limitations in role permissions.

Friday 18 October 2013 9:02:17 am

Hi Dailenis

Could you please report an issue on Jira for this ?

Thanks happy.gif Emoticon

Friday 18 October 2013 2:26:01 pm

Hi,

the issue Betsy got was recently resolved, Status Limitation has been added. Same goes for State/StateGroup_* limitation, also recently added.

As for Dailenis issue, I don't know about any ContentSection limitation, I could neither find any in the legacy kernel. Is this coming from an extension? Or is there an issue in the database where this limitation actually should have been named "Section" (which we already support) ?

Modified on Friday 18 October 2013 2:27:13 pm by André R

Wednesday 23 October 2013 2:41:11 pm

Thank you Andre.  I ran an upgrade, restored the permissions I had removed and everything is running well.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from