eZ Community » Forums » eZ Publish 5 Platform » RemoveSiteAccessIfDefaultAccess in...
expandshrink

RemoveSiteAccessIfDefaultAccess in urls with ez5

RemoveSiteAccessIfDefaultAccess in urls with ez5

Thursday 14 August 2014 6:16:28 pm - 3 replies

Hello. I'm a bit stumbled with this feature we had in legacy mode. Sure you remember it. It allowed us to avoid the "siteaccess prefix" in the url when creating urls for the default siteaccess of your website. 

Actually i'm working on a bilingual site and don't know where this is implemented and why it sometimes works while in others it doesn't.

My site is a bilingual spanish/english. Spanish is my default siteaccess. In the spanish site, main menu and link to articles and all of that hasn't that "es" in the urls. They are as expected. http://domain.com/article1, http://domain1.com/catalogo, whatever

But, if i try to implement a language switcher as said in https://github.com/ezsystems/ezpu...ions/siteaccess/language_switcher.md

i get urls like http://domain/es/article1, http://domain1.com/es/catalogo for the spanish ones.

how can avoid that "es" to appear in this urls? Is there any ez5 config for this?

Thank you

Wednesday 10 September 2014 11:12:59 am

Hi Carlos

It is indeed not possible at the moment, but should be quite easy to fix by adding a condition in the base URL Generator. I guess a setting, semantic + internal, would not hurt of course happy.gif Emoticon

Wednesday 10 September 2014 12:00:55 pm

Be aware of the cache issue with this settings in legacy, url should not end up being accessible both with and without the site access part imo.

Wednesday 10 September 2014 12:09:26 pm

@André, i have to recheck, but i think that's is exactly what happens now with demobundle... 

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from