This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » eZ Publish 5 Platform » Routing issue after upgrading from...
expandshrink

Routing issue after upgrading from 2012.12 to 2013.11 (solved)

Routing issue after upgrading from 2012.12 to 2013.11 (solved)

Wednesday 18 December 2013 2:46:17 pm - 1 reply

After upgrading from 2012.12 to 2013.11 it worked fine on my OS X development installation, but on the staging server (CentOS) I got the following error:

Fatal error: Class 'eZ\Publish\Core\MVC\Symfony\SiteAccess\Matcher\Map\Uri' not found in /var/www/html/vendor/ezsystems/ezpublish-kernel/eZ/Publish/Core/MVC/Symfony/SiteAccess/MatcherBuilder.php on line 37

Turns out my ezpublish/config/ezpublish.yml had the wrong URI routing configuration.

The match rule was Map/Uri where as it now has to be Map/URI.

So it should be:

 
Map\URI:                
     dev: plain_site_user
     admin: plain_site_admin
 

instead of:

Map\Uri:                
     dev: plain_site_user
     admin: plain_site_admin
 

This is probably due to the nature of OS X ignoring cases in filename and took me a while to figure it out, but hopefully someone else finds this post useful in the future happy.gif Emoticon

Modified on Wednesday 18 December 2013 4:43:57 pm by Jani Tarvainen

Friday 21 November 2014 12:15:21 pm

This was still an issue in 2014.11, but it has been reported and a pull request for a fix is in place:

https://github.com/ezsystems/ezpublish-kernel/pull/1097

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from