This site has been archived. To learn more about our current products Ibexa Content, Ibexa Experience, Ibexa Commerce head over to the Ibexa Developer Portal

eZ Community » Forums » eZ Publish 5 Platform » [SOLVED] eZ Community 2014.05 upgrade

[SOLVED] eZ Community 2014.05 upgrade

[SOLVED] eZ Community 2014.05 upgrade

Thursday 05 February 2015 6:00:02 pm - 5 replies


I'm trying to upgrade eZ (legacy stack) 2013.9 to 2014.05.2. So far I've grabbed composer.json and ezpublish/config/EzPublishKernel.php from github tag 2014.05.2 into the project.

Launching composer update:

 php -d memory_limit=2048M -d apc.enable_cli=0 composer.phar update

Prints this error message:

[Symfony\Component\Config\Definition\Exception\InvalidConfigurationException]  Unrecognized option "ezpublish" under "security.firewalls.ezpublish_front"

I think it's kind of related to this other topic

but I feel like I'm still missing a piece of the puzzle here.


What to do ?

Modified on Friday 06 February 2015 4:35:18 pm by Jean-Baptiste Bouhier

Friday 06 February 2015 1:10:32 pm

Hi Jean-Baptiste,

Try removing "ezpublish: true" from "ezpublish/config/security.yml".

Friday 06 February 2015 2:47:41 pm

This is my current security.yml file.

Like you've suggested I've tried changing "ezpublish: true" to false line 33 on the gist.

Composer still pops the same error.

Modified on Friday 06 February 2015 2:48:17 pm by Jean-Baptiste Bouhier

Friday 06 February 2015 3:52:27 pm

Could you remove the entry altogether? I believe it was deprecated somewhere along the line. I'll try to find some documentation to validate that.

Here's the doc:

In ezpublish/config/security.yml, under ezpublish_front firewall, update to fit the following (be sure to remove ezpublish: true)

Modified on Friday 06 February 2015 3:54:36 pm by Gareth Arnott

Friday 06 February 2015 4:32:57 pm

Oh yes, I was following an other page of documentation where it wasn't mentioned.

I still have to update other configuration files (composer update errors) but I think I've got it now.


Thanks a bunch Gareth.

Saturday 07 February 2015 9:21:08 am

Hello Jean-Baptiste,

Could you help us out and login to and click the question resolved icon at the top of your original forum message title?

It's the box with the checkbox inside. It turns green when you have clicked it correctly.

Doing this indicates your question has been solved, you don't need to edit the thread title.

Thanks again for your continued support!


Modified on Saturday 07 February 2015 9:21:26 am by // Heath


You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from