eZ Community » Forums » General » anyone else having problems with page...
expandshrink

anyone else having problems with page offset commands?

anyone else having problems with page offset commands?

Wednesday 30 April 2003 1:34:56 am - 9 replies

they seem to fail miserably and call line 120 in view.php as the source of the prob. Can't figure it out tho. I mean, it doesnt work even in the admin which means I cannot browse more than one page of content in a node.

Modified on Wednesday 30 April 2003 1:50:51 am by Dan Zembrosky

Wednesday 30 April 2003 2:33:02 am

I just did a fresh install with the XP installer on another machine. The Navigator simply does not work. When attempting to view any offset/# it returns that the object is unavailable. I will report this as a bug momentarily.

Sunday 04 May 2003 8:27:27 am

Yep .. I see this too .. it is on a more or less "clean" 3.0.2 install .. running on linux ..

Damn!

Kindest,
Jørgen

Monday 05 May 2003 1:25:48 pm

What are the url's you trying (both the original and the one with the offset), could you paste the path parts in the forum here?

What PHP version are you using?

Wednesday 07 May 2003 9:42:27 am

Fix for this problem.
Index: kernel/classes/ezcontentobject.php
===================================================================
--- kernel/classes/ezcontentobject.php (revision 2412)
+++ kernel/classes/ezcontentobject.php (working copy)
@@ -1680,7 +1680,7 @@
include_once( 'kernel/classes/datatypes/ezuser/ezuser.php' );
include_once( 'kernel/classes/ezuserdiscountrule.php' );
$user =& eZUser::currentUser();
- $languageCode = $Params['LanguageCode'];
+ $languageCode = $Params['Language'];
$language = $languageCode;
if ( $language == '' )
$language = eZContentObject::defaultLanguage();
Index: kernel/content/view.php
===================================================================
--- kernel/content/view.php (revision 2412)
+++ kernel/content/view.php (working copy)
@@ -48,7 +48,7 @@
$ViewMode = $Params['ViewMode'];
$NodeID = $Params['NodeID'];
$Module =& $Params['Module'];
-$LanguageCode = $Params['LanguageCode'];
+$LanguageCode = $Params['Language'];
$Offset = $Params['Offset'];

if ( !is_numeric( $Offset ) )
Index: kernel/content/module.php
===================================================================
--- kernel/content/module.php (revision 2412)
+++ kernel/content/module.php (working copy)
@@ -75,7 +75,7 @@
"functions" => array( 'read' ),
"default_navigation_part" => 'ezcontentnavigationpart',
"script" => "view.php",
- "params" => array( "ViewMode", "NodeID", "LanguageCode" ),
+ "params" => array( "ViewMode", "NodeID" ),
"unordered_params" => array( "language" => "Language",
"offset" => "Offset" )
);

Wednesday 07 May 2003 10:48:32 am

I'm so glead that you finde for us this solution

Menyhert

Thursday 08 May 2003 1:36:38 pm

I made the changes in 302 and later in rev 2414
It is not working for me.
http://dummy.tld/index.php/admin/content/view/sitemap/2/
http://dummy.tld/index.php/admin/content/view/sitemap/2/offset/15

Linux gamma 2.4.20
Apache/1.3.26

<strong>solved:</strong>
I took the three 301 files and made the changes.
It works.

Greetings, ekke

Modified on Friday 16 May 2003 2:50:08 pm by Ekkehard Dörre

Friday 16 May 2003 6:33:06 am

Can someone please tell me how to apply this fix.

Obviously this fix is being presented in a standard format, but I am unfamiliar with it. I assume it is a script for an editor of some sort.

Thank you for informing me of what this is. I am stuck in my attempt to learn how to use eZ Publish until I can fix this.

Joel

Modified on Friday 16 May 2003 6:34:10 am by Joel Finkel

Friday 16 May 2003 10:33:10 am

@ Joel: View the last posting in the tread:

http://ez.no/developer/ez_publish..._object_not_available_reported_bugs_

Greetings, ekke

Modified on Friday 16 May 2003 10:34:11 am by Ekkehard Dörre

Friday 16 May 2003 6:08:40 pm

Thanks, Ekke. Now I see that the lines to be changed are given within the context of the code. Very nice.

The changes work just fine.

Joel

Modified on Friday 16 May 2003 6:10:17 pm by Joel Finkel

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from