eZ Community » Forums » General » Blank admin page following Clear Cache
expandshrink

Blank admin page following Clear Cache

Blank admin page following Clear Cache

Friday 14 November 2014 2:13:33 pm - 5 replies

Hi everyone,

 

I have some troubles with the admin page access. Everything was working well, but I made a mistake on the override.ini.append.php file, and cleared the cache just after throught the backend GUI (clear all cache).

I had an original override.ini.append.php file so I just overwrite the mistaken one, cleared the cache again (deleting files in var/ini folder as I don't have access to backend anymore).

But unfortunately, the admin page is still totally blank (source code is blank also).

 

Do you have any idea how to get back the admin page access?

 

My ezPublish version is 4.x.x if I remember well, and the system is installed on a Debian Server.

 

Thanks in advance for your help,

Friday 14 November 2014 2:26:47 pm

Hello Fabien,

 

I think you will need to use ssh, ftp, sftp access to the server to correct your mistaken ini setting change and clear all caches manually.

This is just one of many reasons why I strongly discourage using the admin to make ini settings changes.

If your still having problems tail the var/log/error.log, clear all caches, reload the admin and review the error log entries to learn more about the run time problems with the site/admin.

Cheers,
Heath 

Modified on Friday 14 November 2014 2:43:24 pm by // Heath

Friday 14 November 2014 3:21:01 pm

Hi Heath,

 

Thanks for your answer.

In fact, first I overwritten a wrong file for override.ini.append.php of the admin siteaccess (using SFTP). Then I cleared the cache  throught the GUI.

Just after a overwritten the good override.ini.append.php file into the admin siteacess (using SFTP also). Then I cleared the cache, deleting the files into var/cache.

 

I have access to SSH / SFTP, and now the  override.ini.append.php into the siteacess (of the admin backend) is the good one (the one I had before the mistake). But still blank page at the admin url...

For information, I used URL redirection so if the admin url didn't exist anymore I should have a redirection to the root of my website. So it seems that the admin URL is still OK, but the page is blank.

 

Do you need more details? Do i have to "rebuild" something?

Friday 14 November 2014 4:04:36 pm

Hello Fabien,

Ahh I understand your situation a bit more clearly.

You should clear all caches which means you need to clear the cache directory under your admin siteaceccss site.ini.append.php's [FileSettings] VarDir

You also need to download and review your error logs to find out what is going wrong on page load (again clear all caches first).

Simply restoring the settings file may not be the solution to all your admin problems.

I do not know what your talking about with regards to admin url redirection but it sounds like a very bad idea.

Cheers,
Heath

Friday 14 November 2014 4:19:04 pm

Hi Heath,

 

Great news. You're right. There was another cache folder which I didn't purge (var/xxxxx/cache/). Previously, I purged only the var/cache folder. I removed all files and I can access to the admin page now.

 

About the URL redirection, I mean that all 

My admin url is www.mywebsite.com/mywebsite_admin, so if this url didn't exist it would bring me back to the www.mywebsite.com. And it was not the case, so I was sure the adress was still valid.

 

Anyway, thank you very much for your prompt help on this case... I will pass a better week-end blunk.gif Emoticon

Regards,

Friday 14 November 2014 4:43:52 pm

Hello Fabien,

I'm so happy I was able to help guide you to the solution you needed to clear all caches and restore your admin siteaccess! Thank you for being so verbose and detailed in your messages it really helps us all better understand.

Have a fantastic weekend!

PS. Thank you for marking this thread as solved!

Cheers,
Heath 

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from