This site has been archived. To learn more about our current products Ibexa Content, Ibexa Experience, Ibexa Commerce head over to the Ibexa Developer Portal

eZ Community » Forums » General » Clear Cache - All Images deleted
expandshrink

Clear Cache - All Images deleted

Clear Cache - All Images deleted

Wednesday 03 October 2012 9:54:44 am - 7 replies

Hi..

Some days ago I "Cleared Cache" and all my Images seems to be deleted.

I use eZ Publish 4.3.0 on my homepage www.beichmann.net

I have tried to upload images after this but it doesn't work.

In the imagefolder it seems like the pictures still are there, but I can't preview, edit or download them.

How do I solve this?

Wednesday 03 October 2012 11:04:03 am

If the images are still there it might hint about problem with ImageMagick/GD, see:
http://share.ez.no/forums/install...che-deletes-images/(language)/eng-GB 

Modified on Wednesday 03 October 2012 11:04:32 am by André R

Wednesday 03 October 2012 5:59:27 pm

1. how did you "clear the caches", by the GUI or by deleting some folder hand on the filesystem?

2. check permissions on the var/folder: can the apache user read/write from it?

3. can you create new images to new content and view them?

Wednesday 03 October 2012 9:41:01 pm

Hi AndreI found eZcache, but don't see where I am supposed to do any changes?And hi to you Gaetano.1. I cleared it in the GUI, by selecting the button "clear the cashes"2. Var/folder? Where do I find this? This is new stuff for me happy.gif Emoticon3. No. I have tried to upload new images, but it doesn't work. I don't get any error codesAny tip?

Wednesday 03 October 2012 10:14:01 pm

Gaetano:I found the var/folder. Inside this folder I found a log/folder.In this error.log I found a lot of messages like this:eZimageManager::createImageAlias"Failed converting var/ezwebin_site/storage/images/media/images/(image name) to alias 'medium' in directory......."

Thursday 04 October 2012 9:45:49 am

HI.

We had the exact same thing happen some time ago on a website.  The research pointed to an evil combination of:

  • how we referenced images in our image.ini
  • and something to do with hard links
  • it is also possible that 4.3 was the cause when the above two are mixed in a certain way

So, I can't remember the exact cause, but the end result was something silly like an image alias was actually referenced via a hard link to the original image, so clearing the aliases with ezcache and --purge gladly removed the aliases and by way fot he hard link, the original image!  

A restore from backup was the solution and we completely re-did our image.ini from the defaults again. An interesting point is that even though this was an ezpublish 4.4 install, the images would have been created when the site was actually 4.3

When knowing how eZ Publish used hard links and looking at our image.ini, it became apparent that what happened was, in fact, possible through sheer goofiness.

I will have to take some time to search our tickets and wiki to find the issue, but perhaps the info provided already can help you search the forums for the issue. Terms like:

  • ez Publish Hard Link Image alias
  • original images deleted hard link image.ini
  • hundreds of hard links ez publish

If I find the details on the root cause of the issue, I will re-post. However, for us, we fixed it and prayed and only months later stumbled across the root cause when researching gazillions of hard links related to backups.

Monday 15 October 2012 9:02:51 pm

I have now cleared the caches by using the shell:# php bin/php/ezcache.php --clear-all --purgeAll the images are back on the homepage, but in the backend, there are still images that I can't "see".And I can't upload new images. I don't get any error-messages..Any tip?

Friday 04 January 2013 2:24:48 pm

i had the same issue after using --clear-all --purge. all aliased images were deleted. 

i neede to execuete --clear-all again and the images started to generate again. 

normal installation, btw. i mean, no db nor dfs cluster. 

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from