This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » General » Content tree in administration - No...
expandshrink

Content tree in administration - No all elements.

Content tree in administration - No all elements.

Monday 22 November 2010 5:29:27 pm - 8 replies

Hi all,

I'm facing a problem with the content tree at left of the admin. I have some classes defined (village, identity card, etc) which I would have in this tree. I overrided my site_admin siteacces with contentstructuremenu.ini.append.php :

[TreeMenu]
Dynamic=disabled
ShowClasses[]
ShowClasses[]=folder
ShowClasses[]=user_group
ShowClasses[]=documentation_page
ShowClasses[]=event_calender
ShowClasses[]=frontpage
ShowClasses[]=forums

ShowClasses[]=village
... 

I clear my cache from administration or directly on the server with :

php bin/php/ezcache.php --clear-all --purge

without success sad.gif Emoticon

The content tree displays some villages but not all, for a little of them, I have a subtree but it's ramdom...

Any ideas ? Thanks in advance for answer.

Modified on Thursday 25 November 2010 11:29:06 am by Matthieu Poignant

Monday 22 November 2010 5:55:34 pm

Make sure you don't have a contentstructuremenu.ini.append.php in settings/override/ that would override all these.

Also try php bin/php/ezcache.php --clear-all --purge -s your_site_access

Sometimes the cache are stubborn so try to manually delete var/cache in your eZ Publish folder.

Monday 22 November 2010 6:38:43 pm

Hello,

Thx for your response, I tried your command, and I deleted my cache folder, I still have the problem. I don't understand, it's very random sad.gif Emoticon

Monday 22 November 2010 9:12:55 pm

Try to change

[TreeMenu]
Dynamic=enabled

Monday 22 November 2010 9:27:56 pm

And also may be this post will do the job. Check this out. http://share.ez.no/forums/developer/content-structure-menu-issue

Tuesday 23 November 2010 10:14:37 am

I tried your propositions, nothing change...
Are translations may affect the display? By viewing the contents of the table ezcontentobject_name I saw that the field was sometimes content_translation eng-GB, while all my items are supposed to be in french.
Yet in the admin, if I look at the language of objects that don't appear in the tree, the language is french.

Tuesday 23 November 2010 5:00:55 pm

Try to add a translation to one missing object to see if it appears.

Then double check how you setup your language settings.

Thursday 25 November 2010 10:11:05 am

Try to add a translation to one missing object to see if it appears.

Then double check how you setup your language settings.

I tried that yesterday, without succes either. Perhaps I have a problem with my installation. But I can't reinstall, there are many datas I wouldn't lose.

I tried to export my content tree to another installation of eZ Publish, but I encounter the same problem.

Monday 29 November 2010 7:03:16 am

Maybe others content "village" are under another content which his class is not displayed in your contenttreemenu?

Modified on Monday 29 November 2010 7:06:57 am by Daisy Radix Leroy

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from