This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » General » ez 4.1.x < + php5.3 mail bug
expandshrink

ez 4.1.x < + php5.3 mail bug

ez 4.1.x < + php5.3 mail bug

Monday 05 April 2010 4:01:06 pm - 1 reply

Just writing this as a tip to help anyone who might get caught out by this. If you happen to run any ez sites that are 4.1.x or earlier on php5.3 email notifications will fail. The solution is simply to copy kernel/classes/notification/eznotificationtransport.php from 4.2.x site or of course upgrade eZ.

No errors make it into var/log/error.log and sending a test email via the ezadmin add-on will still succeed. But if you manually run the cronjob with debug you will get the following.

<code>Warning: (PHP)
Undefined variable: impl in /var/www/mysite/kernel/classes/notification/eznotificationtransport.php on line 83
Error: (eZNotificationTransport::instance)
Transport implementation not supported: ezmail</code>

Hope this helps someone.

Tuesday 06 April 2010 11:57:32 am

Thanks for sharing this Brendan, this is useful.

Cheers,

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from