eZ Community » Forums » General » Google finding the wrong "design" on...
expandshrink

Google finding the wrong "design" on multiple site access installation.

Google finding the wrong "design" on multiple site access installation.

Monday 17 June 2013 3:12:18 am - 2 replies

I have 4 separate sites hosted on one server, in one Ezpublish 4.1.3 installation, (currently trying to upgrade but the 27 gig DB is causing us problems).They all have their own separate domains, but sometimes google picks up content with the design (skin)  from one of the other site accesses on the wrong site.

I have one robots.txt file in my server root, but I cant stop Google from finding the content from one site without stopping it from finding it on the site it is actually supposed to be found on. Am I making sense ?

Is there a way to stop Ezpublish showing content from another site with the wrong design (skin) on it ?
Maybe there is something simple I overlooked when we launched the site several years ago?Its starting to get pretty embarrassing. Really hoping for some pointers here : )

Monday 17 June 2013 6:11:21 pm

One way to work around the problem is to have different anon users, one per siteaccess: first create the users in the backoffice, then change anon user id in site.ini

If your content is neatly separated, you can then give each anon user only read permissions on the content pertaining to the current siteaccess.

Of course, some badly written code assumes a fixed user id of 10 for anon user...

Monday 17 June 2013 10:33:43 pm

Quote from Gaetano Giunta :

One way to work around the problem is to have different anon users, one per siteaccess: first create the users in the backoffice, then change anon user id in site.ini

If your content is neatly separated, you can then give each anon user only read permissions on the content pertaining to the current siteaccess.

Of course, some badly written code assumes a fixed user id of 10 for anon user...

Ok. That sounds promising. So it would stop this kind of thing ?

http://www.gns.cri.nz/Home/About-Us
http://www.naturalhazards.org.nz/Home/About-Us

So I cant use "user 10" . I only have 4 sites so that shouldn't be a problem.

Its not like users are hopping from one design to another, the pages are all being dredged up by google. Will google understand anonymous user ids?

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from