eZ Community » Forums » General » How to disable cache for a specific...
expandshrink

How to disable cache for a specific template

How to disable cache for a specific template

Monday 29 November 2010 3:24:03 pm - 4 replies

Hi,

I am experiencing problem with a particular template being cached. The template actually exists inside an extension.In siste.ini we enabled the template caching. Is there any way to disable caching for this particular template?

Thanks,

John

Tuesday 30 November 2010 8:05:37 am

Hello John,

Try adding this to templates you wish to remain uncached.

{set-block scope=root variable=cache_ttl}0{/set-block}

I hope this helps.

Cheers,

Heath

Tuesday 30 November 2010 10:43:04 am

Hello John,

Try adding this to templates you wish to remain uncached.

{set-block scope=root variable=cache_ttl}0{/set-block}

I hope this helps.

Cheers,

Heath

I added this , but there is no change. It is still caching the template. Any idea?

Friday 10 December 2010 12:09:29 pm

We have had the same problem since upgrading from eZ Publish 4.2 to 4.3. The above line was always there in the template, and it used to work before the upgrade.

Help!

Wednesday 05 January 2011 6:09:25 am

Disable cache

Follow the following instruction.

1. Go to your template file:
eg:
E:\xampp\htdocs\ezpublish\settings\siteaccess\your_site\site.ini.append.php

2. Place the following code:

[DebugSettings] DebugOutput=enabled DebugRedirection=disabled DebugToolbar=disabled DebugByIP=disabled DebugByUser=disabled  [TemplateSettings] TemplateCompile=disabled TemplateCache=disabled DevelopmentMode=disabled ShowUsedTemplates=enabled Debug=disabled ShowXHTMLCode=disabled  [ContentSettings] ViewCaching=disabled  [DatabaseSettings] SQLOutput=disabled 

Go and enjoy the code !!!!!!

For detail follow the link below:

http://blog.developeronhire.com/tag/disble-cache/

Regards,

Sujeet

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from