This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » General » Image display trouble
expandshrink

Image display trouble

Image display trouble

Monday 03 November 2003 2:30:23 am - 15 replies

I'm quite new to ezPub. I'm using the latest 3.2-3 release. I've installed all the demo sites for learning purposes, and also followed the "Building an eZ publish site". The images I've uploaded to the TSCM "Building an eZ publish site" site won't display, and the images in the gallery demo won't show either, and uploading new images to both the included 'flowers' folder and to a new test folder.. all I get in the html sources is lines like this:

<img src="/var/gallery/storage/variations/image/p/h/p" />

as you can see, the name of the images won't parse into the html files..

Any solution? It was like this in 3.2-2 also. I'm using the TSL 2.0 distribution, with apache 2.0.47 php 4.3.2 and mysql 4.0.15

Modified on Monday 03 November 2003 2:30:57 am by Christopher Thorjussen

Monday 03 November 2003 4:00:26 pm

Are you using ImageMagick or GD? I would check to make sure that one or both are installed on the server. If you are trying to use GD, you will need to change the settings in image.ini. I don't recall what they are at the moment, but a quick search of the forums should pull up a message with the fixes if you need to make the changes.

Alex

Monday 03 November 2003 10:31:12 pm

If you're not using ImageMagick, you must change a file called settings/image.ini.append(.php)
look for "convert" and changed them to "gd".
Usually, the setup wizard should have done that for you.

Please try to insert an image into an article with the size setting of "original". This should give you the uploaded image file.
If this works, but the other sizes (and preview in admin site) don't, then your image conversion (ImageMagick's convert or the PHP-GD-Library) don't work or cannot store their results into /var/storage/....

Modified on Monday 03 November 2003 10:32:58 pm by Marco Zinn

Tuesday 04 November 2003 1:00:44 am

Sorry for not mention this.. which I should have thought of to be of necessary info. Yes, I'm using gd from withing php4. I will look into the ini settings.

Update:
I didn't have a "settings/image.ini.append(.php)" file, but i guess you meant "settings/override/image.ini.append.php" which exist:
<?php /* #?ini charset="iso-8859-1"?

[ConverterSettings]
UseConvert=false
UseGD=true
*/ ?>

Will check the "original" setting. (not done yet)

I've also found this info: http://www.ez.no/developer/ez_pub...leshooting/ez_publish_3_and_apache_2 and I've tried to apply "AcceptPathInfo On" to both httpd.conf and .htaccess with no luck.

I'm now checking my setup against this doc: http://www.ez.no/developer/ez_pub...n/troubleshooting/images_do_not_work

Note: Adding an image to the gallery demo without actually supplying a local image path+name works.. a but in the object class?

Modified on Tuesday 04 November 2003 1:26:50 am by Christopher Thorjussen

Tuesday 04 November 2003 1:51:02 am

There seems to be a bug in the Installer/Setup Wizard. Even though the Wizard detects that gd is to be used during setup, it fails to add some options to the "/settings/override/image.ini.append.php" file. It correctly tells eZp to use GD and not convert, but it fails to make a rule of the conversions. You can see my old original image.ini.append.php file in my previous post, and my new fixed image.ini.append.php file her:

<?php /* #?ini charset="iso-8859-1"?

[ConverterSettings]
UseConvert=false
UseGD=true

[GDSettings]
HasGD2=true

[Rules]
DefaultRule=image/jpeg;gd
Rules[]=image/jpeg;image/jpeg;gd
Rules[]=image/png;image/png;gd
Rules[]=image/gif;image/png;gd
Rules[]=image/xpm;image/png;gd
Rules[]=image/tiff;image/png;gd

*/ ?>

I don't know if the "HasGD2" setting has to be included, but php4 has gd2 included, so it seems to be the right option to set if gd is chosen by the Wizard...

I've filed a bug report on this one... http://www.ez.no/developer/ez_pub...s_to_imageiniappendphp_when_using_gd

My only question now is why my original image appears to get resized into a bigger image.. but that's perhaps only the sitesetting of the gallery demo?

Modified on Tuesday 04 November 2003 2:05:35 am by Christopher Thorjussen

Tuesday 04 November 2003 3:57:22 am

Doest solve for me ...

Some problem, tried this patch, but no images ...

Tuesday 04 November 2003 11:45:16 pm

So you are using php4 with the included gd library and doesn't get the images when you upload them? do they get uploaded into /var/storage/image/phpXXXXXX.jpg ?

Did you check this doc: http://www.ez.no/developer/ez_pub...n/troubleshooting/images_do_not_work ?

Modified on Tuesday 04 November 2003 11:48:19 pm by Christopher Thorjussen

Wednesday 05 November 2003 1:00:08 am

problem solved ...
after the changes to /settings/override/image.ini.append.php i uploaded the images again.

The images are stored at var\tscm\storage
at original, reference and variations folder.

axel

Thursday 06 November 2003 7:29:23 am

Good.

After I did what I did, the images that comes with the gallery demo site also showed up, together with those I uploaded AFTER the image.ini.append fix..

Saturday 08 November 2003 5:12:08 am

-

Modified on Saturday 08 November 2003 5:34:56 am by Christopher Thorjussen

Saturday 08 November 2003 2:35:44 pm

I use GD2 on shared server.

What I found out is, that modifying
image.ini.append or image.ini.appen.php in settings/override has absolutely no effect, which means: there are no Images.

But if I modify image.ini itself, than works fine.

(test with the last four EZ releases)

Monday 10 November 2003 1:53:35 pm

I have Ez 3.2.3 installed on a Rh9 system with php 4.2.2 and gd 1.8.4 and tried all of the above mentioned suggestions to get my images displayed (and I have cleared the caches) - but it still doesn't work. Have I forgotten something?

The symptoms are as mentioned above: When looking at the html source, the image source address seems to be wrong: <img src="/var/delta/storage/variations/image/p/h/p" width="0" height="0" border="0" alt="" />

There are files stored only in directory "/var/delta/storage/original/image/", no other directories.

Modified on Monday 10 November 2003 2:09:03 pm by Gunnar Birkeland

Monday 10 November 2003 2:23:50 pm

I had same problem.
(ImageMagick)
But in my case for some files variations was created for others not. Then I changed extension to lowercase. Now everything is ok happy.gif Emoticon

Best
Tomek

Monday 10 November 2003 2:26:32 pm

Gunnar, did you remove this part from the ini file?

[GDSettings]
HasGD2=true

You don'thave GD v2....

Monday 10 November 2003 3:50:03 pm

Yes, the settings are:
[GDSettings]
HasGD2=false
in image.ini

I have also tried to put them in settings/override/image.ini.append.php, bit it didn't help.

My *.png files also have lower-case extension names.

I forgot to mention: My apache version is httpd-2.0.40, should I try 1.3.xx?

Thursday 04 December 2003 2:48:14 pm

Hi

This bug has been fixed in rev. 4355. Thanks for all the input.

--
Kåre Høvik

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from