This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » General » Multiplexer still buggy in 3.2 ?
expandshrink

Multiplexer still buggy in 3.2 ?

Multiplexer still buggy in 3.2 ?

Monday 22 September 2003 11:10:01 am - 3 replies

I've made a workflow with 1 multiplexer event, which is set to work for any section, contentclass id 2 (articles) and no workflow for guest users. If it meets the criteria, an approval workflow is started.

Then I created a new user (class id != 2), but as soon as I pressed "Send for publishing" I got a white page in IE. The same action in Firebird resulted in this:

Fatal error: Call to a member function on a non-object in c:\ezp31beta1\ezpublish-3.2-1\kernel\classes\workflowtypes\event\ezmultiplexer\ezmultiplexertype.php on line 177

The debug output contained a bit more information:
[ Sep 22 2003 11:00:13 ] [127.0.0.1] Timing Point: Module start 'content'
[ Sep 22 2003 11:00:13 ] [127.0.0.1] Undefined offset: 0 in c:\ezp31beta1\ezpublish-3.2-1\kernel\classes\ezcontentobjecttreenode.php on line 2064
[ Sep 22 2003 11:00:13 ] [127.0.0.1] Undefined variable: userID in c:\ezp31beta1\ezpublish-3.2-1\kernel\classes\datatypes\ezuser\ezuser.php on line 177
[ Sep 22 2003 11:00:13 ] [127.0.0.1] Missing main operation memento for key: c2a6cc4835485f41303eee5d6d11c7a1
[ Sep 22 2003 11:00:13 ] [127.0.0.1] Undefined index: user_id in c:\ezp31beta1\ezpublish-3.2-1\kernel\classes\ezworkflowprocess.php on line 156
[ Sep 22 2003 11:00:13 ] [127.0.0.1] Undefined index: node_id in c:\ezp31beta1\ezpublish-3.2-1\kernel\classes\workflowtypes\event\ezmultiplexer\ezmultiplexertype.php on line 175
[ Sep 22 2003 11:00:13 ] [127.0.0.1] Cannot fetch node from empty node ID

This is exactly the same error as before, but I thought this had been fixed (as suggested in various forum messages). Anyone else experiencing this issue?

--
Hans

Modified on Monday 22 September 2003 11:10:22 am by Hans Melis

Monday 22 September 2003 12:24:32 pm

Yes it is still there. I *think* that error is the same one that I was getting so the fix may or may not help. I managed to snap it up while svn was still up and if you like you can email as others have done and I can send it to you. I'm starting to feel like an svn server happy.gif Emoticon

willie dot seabrook at levity dot co dot nz

Monday 22 September 2003 1:29:19 pm

Are you sure you have a newer version of the file? This is the stable ezp 3.2 release (svn rev 3500 according to the admin interface).

I thought the fixes were done before the stable release.

--
H

Monday 22 September 2003 1:35:45 pm

Well the version I downloaded was the 3.2 release (on the day ez released the final). I'm not sure what svn it is.

Anyhow, I installed it and found that I was getting exactly the same error in 3.2 as I was in 3.1 before I dropped the fix into 3.1. So I ran a diff on the files - they were different and so I dropped the fixed file into 3.2 to replace the 3.2 file and everything worked perfect again.

Regards,
Willie

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from