eZ Community » Forums » General » No preview while editing - EZ...
expandshrink

No preview while editing - EZ Publish 4.7 Enterprise

No preview while editing - EZ Publish 4.7 Enterprise

Tuesday 20 May 2014 5:40:56 pm - 7 replies

I'm very new at this so forgive me if my question is very basic. I am editing an existing page through the admin log-in. When I click the preview button I get the old version without my updates. If I save draft, exit and go back and click the preview I still get the old version. 

When I click the edit button for the draft I get a message saying "Your selected translation does not match the language of your selected site access. This may lead to unexpected results in the preview, however it may also be what you intended." I tried two options available for translation. No error but it still does show any changes I made.

Thank in advance for your help

Wednesday 21 May 2014 3:48:33 pm

Are you clearing the cache properly ?

Looks like a cache problem to me.

Thursday 22 May 2014 3:15:37 pm

Thank you very much for the reply.

I have tried previewing the draft with different browsers (chrome, Firefox and IE). I cleared the cache on all but still the preview does not show the changes. The only time I can see the changes is when I publish the draft.

I can log out, clear the cache, log back in, go to the draft and see my edits when in the edit mode, but when I preview draft it does not show the edits.

Should I be concerned about the "Translation mismatch" message that appears every time I edit the document?

The message says "Your selected translation does not match the language of your selected siteaccess. This may lead to unexpected results in the preview, however it may also be what you intended."

I searched the forum/Internet and could not find anything about that message.

Thanks for you time.

Thursday 22 May 2014 3:26:10 pm

Your welcome,

 

Can you tell me which version of ezpublish you are using ?

Thursday 22 May 2014 8:45:26 pm

The version 4.7.0

Thank you

Saturday 24 May 2014 3:53:30 am

OK!

What I will recomend you to do is turn off all 'CACHE's in your admin siteaccess. (Not your frontend siteaccess.)

and make sure all CACHEs are disabled.

I think this will solve your problem here.

Tuesday 27 May 2014 2:50:39 pm

Thank you Amir.

In the admin siteaccess I see ViewCaching is disabled.I looked in the site.ini within the settings/override folder and the main settings folderi. ViewCache is set to disabled in both places. 

To test, I cleared all Caches, opened the draft and clicked preview. It still does not show my change I made a few days ago.

In the draft, I only added a number after a word. No major changes. This was done a few days ago. I have  not made any changes to the draft since.

[ContentSettings]
ViewCaching=disabled
StaticCache=disabled

Wednesday 04 June 2014 8:33:41 pm

Maybe this is because I am working in the preproduction site?

Anyway, since I am working in the preproduction part of the website, I publish the draft and then inspect it. Not the best solution but it works for now.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from