eZ Community » Forums » General » Notification email are not being sent...
expandshrink

Notification email are not being sent - AGAIN

Notification email are not being sent - AGAIN

Wednesday 23 March 2011 2:33:44 pm - 1 reply

Hello,

I've searched through this forum for some information about problem I've been experiencing and I still have no clue how to deal with it.

Lets start from the beginning. Workflow and notification emails are not being sent. However, there is no problem with feedback form emails - these work just wright. First I thought that there is something wrong with setting an recipient - please, see this post. But I think that the problem is with something else. To be sure, that the configuration is wright I set whole new eZ Publish 4.4 installation. I created an user (Members group) and also set a workflow for approving content. Then I tried to add some forum reply as a user from Member's group (I didn't receive any email - but I set the approval checkbox in notification settings in Dashboard). After approving awaiting content I published another forum reply as an admin and no notification was sent - earlier I added proper nodes to my notifications as an admin and Member's group user.

Oh, I forgot one important thing. The test was performed after applying this patch.

Below you can see the output generated by CRON

Running cronjob part 'frequent' 
Running cronjobs/notification.php at: 17/03/2011 2:55 pm 
Starting notification event processing 
Done 
Completing cronjobs/notification.php at: 17/03/2011 2:55 pm 
Elapsed time: 00:00:01  
 
Running cronjobs/workflow.php at: 17/03/2011 2:55 pm 
Checking for workflow processes 
Status list 
Łańcuch zdarzeń został dopisany do zadań cron job(4): 1  
 
0 out of 1 processes was finished 
Completing cronjobs/workflow.php at: 17/03/2011 2:55 pm 
Elapsed time: 00:00:00

Also, if it helps, you can check PHP configuration of my testing server.

I have no idea how to make it work. Shouldn't it be an out of the box feature? Or maybe there is some problem with server configuration? I can't figure it out by myself so I'm asking you for some help.

Wednesday 23 March 2011 3:26:49 pm

I had a similar problem on my site, but uh... I just can't remember what was the sollution... I think it was something misconfigured in the workflow settings of user policies.

Ivan Švogor had the same problem:

So maybe he solved it in the meantime.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from