This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » General » Problem: "Object is unavailable" /...
expandshrink

Problem: "Object is unavailable" / Kernel error 3 ..

Problem: "Object is unavailable" / Kernel error 3 ..

Sunday 24 April 2005 10:23:51 am - 12 replies

Hi!

I have installed v3.5.0 and today upgraded to v3.5.1 and was hoping this error would go away, but it didn't! Basically what I have done is to have a standard Ez install with "blog" as the one I base my design on. I have done no changes to permissions or done any code changes etc. The only thing I have done is to create some standard template overrides etc ..

.. but I keep getting the "Object is unavailable / Kernel error 3" for my "File" section. IE I want to upload files that I want to share into that folder and have people download and view them if they want, but it does not work. When I access the same files from the admin interface it works like a charm!

Check:
http://www.skogstad.com/ez/index.php/skogstad/files

Here you can see all files listed as 0 bytes.

Click on one and you get the error. Like:
http://www.skogstad.com/ez/index....edusere-gapet-virksomhet-prosess.pdf

I cannot figure out what to do. I need this function and am crossing my fingers someone knows what to do! blunk.gif Emoticon

I have the Site: www.skogstad.com/ez/index.php,
Version: 3.5.1 (3.5.1), SVN revision: 10652, Extensions: Not in use. .. version of Ez now.

Everything else seems to be working fine.

Have anyone else seen this??

Thanks in advance!

With respect,
Jørgen Skogstad

Monday 25 April 2005 11:37:29 am

Hey.

Normally the anonymous users does not have access to any other section than standard.

To give anonymous users access to the Media Section. Do the following:

Click "User accounts" -> "Roles and policies".
Edit anonymous role
Edit the line which says "Content Read Section( Standard )"
Select Standard _and_ Media (usually hold Ctrl to select more). -> ok

Ok again to store the role.

Now you should be able to see the files. happy.gif Emoticon

Monday 25 April 2005 10:10:23 pm

Hey!

Thanks for the swift reply! Tried it, but I could not see the files. Get the same error. Here is what is configured as anonymous policy:

Module Function Limitation
content read Section( Standard , Media )
content pdf Section( Standard )
rss read No limitations
user login SiteAccess( skogstad )
content read No limitations

The result of that even you can see when directing the browser to:

http://www.skogstad.com/ez/index....edusere-gapet-virksomhet-prosess.pdf

Any ideas on how to make this work? The files are in the database and it all works just fine from the administration interface! Strange huh!?!

Thanks in advance!

With respect,
Jørgen

Tuesday 26 April 2005 9:40:22 am

Hi

Have you changed the locale of your user site?

Check the settings in settings/siteaccess/blah/site.ini.append.php and in blah_admin. Are the following settings different?

[RegionalSettings]
ContentObjectLocale=nor-NO

If so.. change the userside (blah) to the same as the admin siteaccess (blah_admin)

Tuesday 26 April 2005 3:22:17 pm

Well; you were correct in that the user and admin side differed. The user side was configured to be nor-NO and the admin to be eng-GB. I changed to user side to be eng-GB, but the error remains the same.

Hmm ..

Any chance you could have a look at it if you had access?

Apreciate your help!!

Thanks!

/Jørgen

Wednesday 27 April 2005 1:56:15 pm

Usually the problem goes away once you change it. Did you clear all the cache after changing the settings?

It shows up correctly on your admin page yes?

Can you connect to the database and run the following query:

select distinct(language_code) from ezcontentobject_attribute;

What is the output?

Thursday 28 April 2005 8:58:08 am

Hey,

Ran the query and got:

eng-GB

.. which is updated into the public config.

Hmm .. as usual I am at a loss! blunk.gif Emoticon

I'll buy you a beer if we manage to solve this!

/Jørgen

Thursday 28 April 2005 1:16:32 pm

Hmm.. Thats strange.

Have you tried to turn on the debug output?

Add the following to settings/override/site.ini.append.php (or settings/override/site.ini.append). Create settings/override/site.ini.append.php if it does not exist.

[DebugSettings]
DebugOutput=enabled

Clear the cache. Are there any errors in the debugoutput?

Thursday 28 April 2005 9:54:13 pm

Tries it and yes; there is an error .. not sure what it means though:

--

[ Apr 28 2005 21:44:36 ] [213.145.166.210] Timing Point: Module end 'error'
[ Apr 28 2005 21:44:36 ] [213.145.166.210] No such attribute for array(7): node_id
Choose one of following: content, path, is_default_navigation_part,
                         navigation_part, ui_context, ui_component,
                         uri
[ Apr 28 2005 21:44:37 ] [213.145.166.210] Cannot retrieve attribute of a boolean
[ Apr 28 2005 21:44:37 ] [213.145.166.210] Cannot retrieve attribute of a boolean
[ Apr 28 2005 21:44:37 ] [213.145.166.210] Cannot retrieve attribute of a boolean

---

Or something similar .. ??!

/Jørgen

Modified on Thursday 28 April 2005 9:54:44 pm by Jørgen Skogstad

Friday 29 April 2005 9:22:03 am

Can you try to delete the file and then upload it again?

If that does not work. Can you create a user under administrator users in admin, and send me the login info (kh curly-a ez dott no), and I will take a look at it.

Tuesday 03 May 2005 6:34:00 am

I am really sorry, but I have unfortunately not had time to look on this yet (I just travelled to the US). But I will try to take a look at it tonight.

Tuesday 03 May 2005 3:22:21 pm

No worries! No hurry! I would rather go around doing other stuff than checking out this... expecially if I was in the states!

Anytime you get around to it .. and have a really nice trip!

Thanks in advance, though!

/Jørgen

Saturday 14 May 2005 10:42:33 pm

Hepp! You had any chance to look at it? Would love your comments. If you need I can also grant you access through ssh.

blunk.gif Emoticon

(Crossing my fingers!)

/Jørgen

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from