This site has been archived. To learn more about our current products Ibexa Content, Ibexa Experience, Ibexa Commerce head over to the Ibexa Developer Portal

eZ Community » Forums » General » Problem when I publish an object with...
expandshrink

Problem when I publish an object with special chars

Problem when I publish an object with special chars

Wednesday 27 October 2010 6:15:12 pm - 4 replies

Hi,
When I publish an object with special chars (for example lambda), I've an error on a red block :

Fatal error: A database transaction in eZ Publish failed.
The current execution was stopped to prevent further problems.
You should contact the System Administrator of this site with the information on 
this page.
The current transaction ID is TRANSID-xxxxxxxxxxxxxxxxxxxxx and has been logged.
Please include the transaction ID and the current URL when contacting the 
system administrator.

I've this problem just when I publish. When I save my draft, my special chars is on my content and I can continue my modifications.
My database is in MyISAM but I was tested in InnoDb with the same result.
The charset is UTF8_general_ci.
Thanks for your solutions.

Modified on Wednesday 27 October 2010 6:17:58 pm by AGUENOT Nicolas

Wednesday 27 October 2010 9:14:34 pm

You will find in the file var/error.log the offending sql query. You can post it here for further analysis

Thursday 28 October 2010 9:22:28 am

Il this file var/log/error.log, I've these error :

eZMySQLiDB: Query error (1271): Illegal mix of collations for operation '
 IN '. Query: SELECT * FROM ezsearch_word WHERE word IN ( ......)

and :

eZDBInterface::commit TRANSID-xxxxxxxxxxxx:Transaction in progress 
failed due to DB error, transaction was rollbacked. Transaction ID is 
TRANSID-xxxxxxxxx.

I think the second error is related to the first.

In addition, my specialChars was not well encoded in the first request.
For example, when I insert the lambda special char, I've this λ in my request.

Thanks for your solutions.

Thursday 28 October 2010 9:38:31 am

If your database is MyISAM, I presume your installation is an older version of eZ Publish or upgrade from older version.

Maybe you can try to backup data, drop and recreate the table in question and then restore data?

Thursday 28 October 2010 9:44:26 am

I've just discovered that my field "word" on my table "ezsearch_word" was encoded in "latin1_swedish".

I changed it to "utf8_general_ci" and I my problem was solved.

Thanks a lot for your help.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from