eZ Community » Forums » General » Problem with open file downloaded...
expandshrink

Problem with open file downloaded using IE

Problem with open file downloaded using IE

Thursday 22 June 2006 12:08:24 am - 9 replies

I have a problem opening file downloaded using Internet Explorer. The temporary file (in Temporary Internet Files) is saved without extension, and the application (for example MSWord, AdobeReader) write message that the file is not found.

For example i download:

sample_filename.doc

but in the temp folder see:

sample_filename[1].

With other browsers I don't have this problem and SaveAs option in IE work properly too. Only opening file from IE works bad sad.gif Emoticon

Any help because I have no idea how to solve this?

<i>
ezp 3.6.8
php 4.3.9
</i>

Modified on Thursday 22 June 2006 12:19:14 am by Dariusz Włodarczyk

Sunday 25 June 2006 6:31:20 pm

Hi,

One of my user reported me an identical result (pdf).

I'll check what's inside the temporary folder.

What's your IE version ?

Sunday 25 June 2006 9:07:00 pm

I test this on IE 6

Monday 26 June 2006 9:29:51 am

Ok,

My client has IE too with SP2. Looks like it's related.

I take for granted that you're tested with Firefox and it works like a charm, haven't you ?

X+

Monday 26 June 2006 3:16:47 pm

Yes exactly!

I think this problem is connected with something in apache configuration too, beacuse this problems starts for me when my client chcange hosting provider. But other systems (not builded on ezpublish) still working correctly with all browsers after this change.

Modified on Monday 26 June 2006 3:18:48 pm by Dariusz Włodarczyk

Wednesday 28 June 2006 12:55:22 pm

Hi,

Any news on your side ? I've the problem both with an apache2 and and apache1.3 site. one in php4.3 the other on php4.4.

This is what I get (FF linux with liveheader extension)

GET /content/download/2152/9698/file/Brochure%20Curriculum%20FR.pdf HTTP/1.1

Host: www.example.org

User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.4) Gecko/20060406 Firefox/1.5.0.4 (Debian-1.5.dfsg+1.5.0.4-1)

Accept: text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5

Accept-Language: en-us,en;q=0.5

Accept-Encoding: gzip,deflate

Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7

Keep-Alive: 300

Connection: keep-alive

Referer: http://www.example.org/fr/domaines_d_action/management_europeen_responsable/publications/un_programme_d_etudes_pour_le_management_europeen_responsable_mer

Cookie: eZSESSIDeurocadres=ecb373e5352232f3cefaacb85e3b6853



HTTP/1.x 200 OK

Date: Wed, 28 Jun 2006 10:51:13 GMT

Server: Apache/1.3.33 (Debian GNU/Linux) mod_perl/1.29 PHP/4.4.2-0.dotdeb.1 DAV/1.0.3

X-Powered-By: eZ publish

Expires: Wed, 28 Jun 2006 11:01:13GMT

Last-Modified: Wed, 28 Jun 2006 10:51:13 GMT

Content-Language: eng-GB

Content-Length: 167967

content-disposition: attachment; filename="Brochure Curriculum FR.pdf"

Content-Transfer-Encoding: binary

Accept-Ranges: bytes

Keep-Alive: timeout=15, max=99

Connection: Keep-Alive

Content-Type: application/pdf


Wednesday 28 June 2006 8:55:18 pm

Today hosting provider of my client upgraded php from 4.3.9 to 4.4.2. So after this I must made upgrade of ezpublish from 3.6.8 to 3.8.1 and problem was gone. Now all working ok (in all browsers), but i'm not sure the upgrading of php was only thing made by provider... maybe they change something more in apache configuration...

So my problem was ended and I wish the same for you blunk.gif Emoticon

Modified on Wednesday 28 June 2006 8:57:07 pm by Dariusz Włodarczyk

Wednesday 25 October 2006 3:41:11 pm

Hi,

I had a similar problem, and it was solved by replacing my old rewrite rule with the one recommended by eZ.

Wednesday 25 October 2006 4:07:30 pm

Hi,

Cold thread, thanks for joining.

Indeed, I had the "all in one line" version.

I'll try this and let you know.

        Rewriterule ^/var/storage/.* - [L]
        Rewriterule ^/var/[^/]+/storage/.* - [L]
        RewriteRule ^/var/cache/texttoimage/.* - [L]
        RewriteRule ^/var/[^/]+/cache/texttoimage/.* - [L]
        Rewriterule ^/design/[^/]+/(stylesheets|images|javascript)/.* - [L]
        Rewriterule ^/share/icons/.* - [L]
        Rewriterule ^/extension/[^/]+/design/[^/]+/(stylesheets|images|javascripts?)/.* - [L]
        Rewriterule ^/packages/styles/.+/(stylesheets|images|javascript)/[^/]+/.* - [L]
        RewriteRule ^/packages/styles/.+/thumbnail/.* - [L]
        RewriteRule ^/favicon\.ico - [L]
        RewriteRule ^/robots\.txt - [L]
        # Uncomment the following lines when using popup style debug.
        # RewriteRule ^/var/cache/debug\.html.* - [L]
        # RewriteRule ^/var/[^/]+/cache/debug\.html.* - [L]
        RewriteRule .* /index.php
 

Thursday 26 October 2006 11:12:35 am

Small correction:

       Rewriterule ^/design/[^/]+/(stylesheets|images|javascripts)/.* - [L]

(javascripts instead of javascript)

First reports: it seems to work better. Why is unclear for me and to be honest, it doesn't make sense. Waiting for more reports...

X+

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from