eZ Community » Forums » General » Problem with sessions | ezsession.php...
expandshrink

Problem with sessions | ezsession.php | session_start()

Problem with sessions | ezsession.php | session_start()

Sunday 08 August 2010 6:43:08 pm - 5 replies

Hi!

After publishing site on hosting server i see this errors.

Warning: PHP: E_WARNING Aug 08 2010 16:35:57
session_module_name() [<a href='function.session-module-name'>function.session-module-name</a>]:
A session is active. You cannot change the session module's ini settings at this time in /home/site/promo.site.com/docs/lib/ezutils/classes/ezsession.php on line 437

Notice: PHP: E_NOTICE Aug 08 2010 16:35:57
A session had already been started - ignoring session_start() in /home/site/promo.site.com/docs/lib/ezutils/classes/ezsession.php on line 520

And I can't login to the admin interface. Automaticly used anonymouse user.

Where is the probem?

I use eZ Publish 4.3.0

Modified on Sunday 08 August 2010 6:50:27 pm by Maxim Kopytov

Sunday 08 August 2010 8:37:57 pm

Hi Maxim,

Can you have a look at the following topic? http://share.ez.no/forums/developer/ez-publish-4-performance-varnish/(offset)/20#comment48709

Regards Robin

Monday 09 August 2010 5:39:03 pm

Tuesday 31 March 2009 6:39:45 pm

Gosh... I get it.

 

session was at auto-start in php.ini.....

My .htaccess file:

php_value session.auto_start 0

And I see this error

[ Aug 09 2010 15:16:07 ] [213.206.44.230] PHP: E_WARNING:
Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/tmp) in Unknown on line 0

Monday 09 August 2010 8:35:37 pm

Hi Maxim,

Could you check the phpinfo for the session auto start? Check if both local and master value are set to "Off".

-- Robin

Tuesday 10 August 2010 7:09:27 am

Hi Maxim,

Could you check the phpinfo for the session auto start? Check if both local and master value are set to "Off".

-- Robin

Hi!

We found the problem!

In first line of index.php file, we found this code:

session_start();

I think that was somebody's malice.

Tuesday 10 August 2010 7:53:07 am

Hi Maxim,

Glad to see this is fixed, could you mark the topic as solved? See your original/first post, there is a checkbox.

Thanks Robin

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from