This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit

eZ Community » Forums » General » Problems registering a new User (eZ 5.4)

Problems registering a new User (eZ 5.4)

Problems registering a new User (eZ 5.4)

Sunday 10 May 2015 1:08:45 am - 4 replies


I have set up a new project using eZPublish 2014.11 downloaded straight from

At the moment I still have it on my computer using localhost (through MAMP)

I have set up a new bundle and have been adding CSS and overriding templates. I have today come to register a new user, and cannot get it to work. (Is is because I am in 'dev' mode and running on localhost?)


When I click on register on the Frontpage, the form comes up, and will send successfully. According to the message on the screen I will get an email to confirm the next steps, but I have not had one after 3 attempts.

Next I tried going back in as an administrator, and to confirm the account activation manually. I can see the new account, and it takes me to the page showing the information added on registration, even the photo. When I try to click to activate though, I get the following error message:

The requested page could not be displayed. (2)

The resource you requested was not found.

Possible reasons:

  • The ID number or the name of the resource was misspelled. Try changing the URL.
  • The resource is no longer available.




In a related error, I also tried (after the other problem) to add a workflow so that the admin has to approve an activation.


Whilst Userregistration1 worked fine, the second section with FinishUserRegistration did not show any of the boxes to actually create the workflow.


Can anybody help please?


Many thanks



Sunday 10 May 2015 1:22:04 am

Further to my question, I later went into my dashboard and could see the new user details as an entry in my drafts.

I clicked on this and there was an option to "publish" which allowed me to publish. I can now log in as the new user, but obviously this is not how it is supposed to work

Is there something else I have to do to be able to have new users register?



Sunday 10 May 2015 1:36:05 am

And now.. when I try to load up any page on the site (even after clearing the cache), I am told that:

User 'HugeFan' doesn't have user/login permission to SiteAccess 'eng'

403 Forbidden - AccessDeniedHttpException1 linked Exception:

  • UnauthorizedSiteAccessException »





I'm totally confused

Monday 11 May 2015 3:15:56 am

Hello Barry,

Ok, you've shared a lot of detail which is good, now I have a lot to respond to big-smile.gif Emoticon

First, your local computer (macos) is configured by default -not- to send email when eZ Publish tries to send out user registration confirmation emails. There are a number of reasons why, one that superseeds is that your laptop is not properly setup to be a mail server in the ways that other mail servers would not by default reject the mail it would try to send (re: spam prevention). If you need to send email but don't want to setup your local machine as a proper mail server then consider using a relay. I've setup smtp auth within eZp to relay email through Gmail to solve this problem in the past. Here is another users successful settings example for this:

Next, By default eZ Publish Legacy user registration requires email user validation (Re: Setting:  VerifyUserType=email ). This means since you currently can't send email you thus can not click the 'activate' user link in the user signup validation email. Now it sounds like you figured out how you can manually activate a user using the admin view (uri, /user/unactivated ) which is version specific but your using the latest version so obviously you have this view.

I did not get the 'activation' error you so briefly alluded too when I tested the same version of eZ your using. Hint next time always, always, always include the uri of the page you get the error message on. My registered user got activated normally and I was able to login without any problems. Remember that user role policy permissions are the reason you got the error message, "User 'HugeFan' doesn't have user/login permission to SiteAccess 'eng'". I can't know without more specifics on your role policies and role assignemnt but I think your user role does not have the required role policy permissions to use user/login on siteaccess 'eng' (Like the error says big-smile.gif Emoticon). In a default installation with the default role policies and assignments, new users via user/register are stored within the 'Members' group which inherit user/login on siteaccess 'eng' policy permissions from the 'anonymous' role. If your role does not have this policy, consider adding it to solve the problem your encountering.

To further compound problems in the middle of all of these getting started issues you started down the path of user registration moderation. User registration moderation is workflow based and often a very helpful tool. Remember that user registration moderation is workflow based which means that when configured and active the following does not happen: User content objects are created (as drafts) but -not- published (within the content tree), also user validation emails (with the user activation link) are not sent -until- the workflow cronjob is run (manually or on a schedule) which will when configured properly send an email to admin users (when the notification cronjob is run) who have subscribed to these notifications (via the notification settings ui in admin). The admin user can then click the collaboration link in the email -or- view the admin collaboration ui to approve the publishing of the user, when sent for publishing, nothing happens again until the workflow cronjob again runs at which point the user content object is published into the content tree and the user validation email is sent to the user. Until the user is activated, the user can not login. Remember that content object (in this case of class user) workflow moderation is different and separate from user validation. Both can be used together, separately or not at all.

I know you need to re-read in detail and study the documentation link you shared as key details in the process that your missing are covered, while I will also admin others that your missing are not properly covered in the mentioned documentation (sorry :\).

To be clear, none of your issues come from you being in 'dev' mode. While some issues your having with mail do come from you being on localhost (on a computer not setup to be a non-spam mail sending server).

Whew. Ok that's some serious walls of text to read but it's the truth of the situation. I think that is about all that I can explain at this point. As always please read, study, try to solve some of the problems your facing and try again. Feel free to ask more follow up questions.

I hope this helps!


Tuesday 12 May 2015 7:42:41 pm

Thanks Heath,

Its definitely due to the localhost. That was the main thing that I needed to know. My plan was to get my site loking how I want it then to put it online and add users at that point, but I needed to know that it was definitley due to localhost or dev settings.

However, you have given me a lot of information here so once I have finished some other things on my list I will look more fully at changing some of these settings to be able to use these functions without having to put the site online. For other projects that will definitlely be very useful, and hopefully somebody else will be looking for answer this questions and they now have a resource ready to go.

Thanks again


You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from