eZ Community » Forums » General » Question about multilingual url_alias
expandshrink

Question about multilingual url_alias

Question about multilingual url_alias

Monday 27 October 2008 11:35:47 pm

I'm wondering about how the multilingual url_aliases is supposed to work? It's currently not working as I was expecting.

I have a site with two siteaccesses; mysite_no and mysite_en, which uses norwegian and english language, respectively. I have the following content:

prosjekter/
mitt_prosjekt/
ez_publish/

Which, when translated looks like:

projects/
my_project/
ez_publish/

I'm using host match. The following URLs are working as expected:

http://www.mysite.no/prosjekter
http://www.mysite.no/prosjekter/mitt_prosjekt
http://www.mysite.no/prosjekter/ez_publish

The following is also working, even though I find it strange:
http://www.mysite.no/projects

For the english site, the following is also working, very good:
http://en.mysite.no/projects

However, this is not working:
http://en.mysite.no/projects/my_project
http://en.mysite.no/projects/ez_publish

And, as with the norwegian site, URLs seem to be "leaking":
http://en.mysite.no/prosjekter

When asking for url_alias of translated $node, I get a system URL (ie /content/view/full/xxxx).

So... How can I get the following scenario?

Should work:
http://www.mysite.no/prosjekter
http://www.mysite.no/prosjekter/mitt_prosjekt
http://www.mysite.no/prosjekter/ez_publish
http://en.mysite.no/projects
http://en.mysite.no/projects/my_project
http://en.mysite.no/projects/ez_publish

Should not work:
http://www.mysite.no/projects(/*)
http://en.mysite.no/prosjekter(/*)

$node.url_alias should be "projects/my_project" in english siteaccess an "prosjekter/mitt_prosjekt" in norwegian siteaccess. Possible?

No reply yet!

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from