eZ Community » Forums » General » Reindexing problem
expandshrink

Reindexing problem

Reindexing problem

Thursday 22 May 2003 4:14:58 am - 9 replies

Following the contribution on how to re-index I used the command:
php4 -C update/common/scripts/updatesearchindex.php

Seemed to work except it finished with
96.1538461538%
98.0769230769%
100%

done
Fatal error: eZ publish did not finish it's request

Why the error?

Thursday 22 May 2003 8:52:01 am

I've seen this as well, actually it happens every time. Not sure what causes the error but it does seem to work OK.

Cheers
Bruce

Thursday 22 May 2003 11:18:22 am

Yep I get that error message too... The routine works, but always with the error...

Thursday 22 May 2003 6:21:21 pm

Thanks good to know its not just me, and that it works anyway. When doing this I was trying to solve this problem, any insights or similar experiences?

Modified on Friday 30 May 2003 7:43:40 am by Brendan Pike

Friday 07 January 2005 2:06:25 pm

I get the following error when running php -C update/common/scripts/updatesearchindex.php:

...................................................................... 9.23076923077%
................................................................
Fatal error: Call to a member function on a non-object in /www/html/vhost/www.juvente.no/kernel/search/plugins/ezsearchengine/ezsearchengine.php on line 79

Fatal error: eZ publish did not finish it's request
The execution of eZ publish was abruptly ended, the debug output is present below.

What goes wrong? How can I fix this?

Modified on Friday 07 January 2005 2:08:41 pm by Eivind Marienborg

Thursday 13 January 2005 10:31:27 pm

I just tried to upgrade from 3.3-3 via 3.3-5 , 3.4.0 and 3.4-4 to 3.5.0 folloving the upgrade steps in the eZ documentation to the letter. I also get

Fatal error: Call to a member function on a non-object in kernel/search/plugins/ezsearchengine/ezsearchengine.php on line 83

when running updatesearchindex.php. Mine got to 24% before craching , and I see that the table ezsearch_word is incomplete. I guess I have an empty field somewhere in some other table making this object become invalid/empty but how can I find out where so I can fix the bugger?

-Chris

Monday 17 January 2005 1:43:52 pm

Undefined index:  db-host in /www/html/vhost/www.juvente.no/update/common/scripts/updatesearchindex.php on line 68

The error occurs after 9.35650181402% of reindexing. Where do I check that the db-host is setup correctly?

Tuesday 18 January 2005 8:56:33 pm

Works for me on 3.5 (started with that version, too):

Starting object re-indexing
Number of objects to index: 82
...................................................................... 85.3658536585%
............ 100%

done

Wednesday 19 January 2005 8:39:10 am

I have about 21,000 objects to reindex.. Can that be the problem?

Friday 16 September 2005 7:13:31 am

Has anyone solved the problem?
I still got it n V 3.5.1

see: http://ez.no/community/forum/developer/updatesearchindex_php_fails_a_bug

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from