This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » General » Roles: "Create" is not enough. Needs...
expandshrink

Roles: "Create" is not enough. Needs "edit". Silly

Roles: "Create" is not enough. Needs "edit". Silly

Thursday 16 October 2003 11:13:39 am - 1 reply

Hi,

I just set up some role, who is allowed to create something.
ez gives me an error (no rights), after showing an "edit" URL.
After that, I also gave the role the edit rights. This worked.

Seems, as "create" will let the role create the object, but it also needs "edit" to really do something with it. When you have no "edit" rights, you will just get a draft without data.
This is silly!
Either this should be WELL documented or "create" should always implicate "edit self-created objects.
Or.... did I make some mistake here?

Wednesday 29 October 2003 10:21:46 pm

That's no mistake. I had the same problem. After spending an hour trying to figure out why I couldn't create content with the proper roles set I came across this post.

I set permissions for edit and create and now it works. Again, is this how you're supposed to set up roles?

-Kagen Tres

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from