eZ Community » Forums » General » RSS feeds not showing, or removing
expandshrink

RSS feeds not showing, or removing

RSS feeds not showing, or removing

Wednesday 15 December 2010 1:03:51 am - 4 replies

I cant find any documentation on exporting RSS anywhere on the ez.no documentation site,
(apart from this) http://doc.ez.no/eZ-Publish/Technical-manual/4.x/Reference/Modules/rss/%28language%29/eng-GB so I am back here.

The default "My RSS Feed" still shows up site-wide in the source of all of the pages. Even if I delete it from the admin interface.
Of course the link is broken if i try to subscribe to it.

Is there a permissions thing I have to do to make my new feed visible?
Can ez only deal with one feed per site access ?

Wednesday 15 December 2010 11:24:04 pm

Ok, I get it, Ezpublish doesnt support multiple RSS feeds on the one siteaccess.
Wow.

Thursday 16 December 2010 3:14:01 am

I take that back.
It doesn't support multiple RSS feeds on the one installation.
Incredible.

Thursday 16 December 2010 10:48:18 am

Hi !

Nice to hear you got things working. How did you fix the old RSS still showing up while being actually deleted ? Caching issue ?

Cheers,

Tuesday 21 December 2010 1:45:05 am

Hi !

Nice to hear you got things working. How did you fix the old RSS still showing up while being actually deleted ? Caching issue ?

Cheers,

I wouldnt say that I got things working, more an understanding that what I was wanting wasn't doable. Not that you would know from reading the documentation, but there are two places that you can set the RSS in Ezpublish, that I have found.

One is:
Set-up >>
RSS >>
RSS-exports

This is documented if you can stumble across it, as searching for it yeilds nothing. I dont have the time to try and hunt it down again, but anyway, you can set up the feeds in here - but unless you have them stated in another place, they will not be picked up by the page's template (my goal).

In order to have the RSS placed in the header of the page, so that a browser will automatically pick it up, and show the RSS icon in the URL bar, it needs to be stated in here:

Design>>
Look and feel>>
Edit>>
Scroll down till you find:
RSS feed

and you need to put in the path of one of the feeds you have set up, ( in the previously mentioned area ) into this "box" /rss/feed/media or whatever the path you have set previously is.

Whatever is in this box will override anything anywhere else, regardless of whether there is anything actually set-up in the RSS-exports area.

My aim was to have the RSS embedded on the relevant page, until I realised that Ezpublish only supports one embedded feed per installation out of the box. I have two site accesses on this installation with their own media pages, so I cant use it at all without getting clever than I am.

Maybe I can do a hack with literal text, or separate hard-coded header templates that call it in.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from